5211 C++ Programming Manual: D:/5211/Cpp Directory Reference

5211 C++ Programming Manual
Cpp Directory Reference

Files

file JY5211.h
@SectionBegin JY5211 FileHead
Generated by doxygen 1.9.1


5211 C++ Programming Manual: D:/5211/Cpp/JY5211.h File Reference

Typedefs | Enumerations | Functions
JY5211.h File Reference

@SectionBegin JY5211 FileHead More...

Typedefs

typedef void * JY5211_DeviceHandle
Windows. More...

Enumerations

enum | JY5211_ReferenceClock { JY5211_Internal = 0x0 , JY5211_PXIe_Clk100 = 0x1 , JY5211_PXIe_DStarA = 0x2 }
enum | JY5211_TimebaseSource { JY5211_Internal_Timebase_200M = 0x0 , JY5211_Internal_Timebase_5M = 0x1 , JY5211_Internal_Timebase_100K = 0x2 , JY5211_External_Timebase = 0x3 }
enum | JY5211_CI_SampleMode { JY5211_CI_Single = 0x0 , JY5211_CI_Finite = 0x1 , JY5211_CI_Continuous = 0x2 }
enum | JY5211_CO_SampleMode { JY5211_CO_Single = 0x0 , JY5211_CO_Finite = 0x1 , JY5211_CO_ContinuousWrapping = 0x2 , JY5211_CO_ContinuousNoWrapping = 0x3 }
enum | JY5211_CountDirection { JY5211_CI_Count_Up = 0x0 , JY5211_CI_Count_Down = 0x1 , JY5211_CI_Count_External = 0x2 }
enum JY5211_CI_MeasureType {
JY5211_CI_EdgeCount = 0 , JY5211_CI_Measure_FrequencyOrPeriod = 1 , JY5211_CI_Measure_PulseWidth = 2 , JY5211_CI_Measure_EdgeSeparation = 3 ,
JY5211_CI_EncoderX1 = 4 , JY5211_CI_EncoderX2 = 5 , JY5211_CI_EncoderX4 = 6 , JY5211_CI_EncoderTwoPulse = 7
}
enum | JY5211_CI_SampleClock { JY5211_CI_NoClk = 0 , JY5211_CI_ImplicitClk = 1 , JY5211_CI_InternalClk = 2 , JY5211_CI_ExternalClk = 3 }
enum | JY5211_LevelState { JY5211_LowLevel = 0 , JY5211_HighLevel = 1 }
enum | JY5211_DigitalTriggerEdge { JY5211_Rising = 0x0 , JY5211_Falling = 0x1 }
enum | JY5211_CIO_StartTriggerType { JY5211_CI_Immediately = 0x0 , JY5211_CI_Digital = 0x1 , JY5211_CI_Soft = 0x3 }
enum | JY5211_Power_Level { Level_1p8 = 0 , Level_2p5 = 1 , Level_3p3 = 2 , Level_5p0 = 3 }
enum | JY5211_SyncMode { JY5211_SyncMode_Sole = 0 , JY5211_SyncMode_Master = 1 , JY5211_SyncMode_Slave = 2 }
enum | JY5211_CI_CounterEventSignalIdleState { JY5211_CI_CounterEventSignalIdleState_Low = 0 , JY5211_CI_CounterEventSignalIdleState_High = 1 }
enum JY5211_IOTerminal {
JY5211_PFI_0 = 0 , JY5211_PFI_1 = 1 , JY5211_PFI_2 = 2 , JY5211_PFI_3 = 3 ,
JY5211_PFI_4 = 4 , JY5211_PFI_5 = 5 , JY5211_PFI_6 = 6 , JY5211_PFI_7 = 7 ,
JY5211_PFI_8 = 8 , JY5211_PFI_9 = 9 , JY5211_PFI_10 = 10 , JY5211_PFI_11 = 11 ,
JY5211_PFI_12 = 12 , JY5211_PFI_13 = 13 , JY5211_PFI_14 = 14 , JY5211_PFI_15 = 15 ,
JY5211_PFI_16 = 16 , JY5211_PFI_17 = 17 , JY5211_PFI_18 = 18 , JY5211_PFI_19 = 19 ,
JY5211_PFI_20 = 20 , JY5211_PFI_21 = 21 , JY5211_PFI_22 = 22 , JY5211_PFI_23 = 23 ,
JY5211_PFI_24 = 24 , JY5211_PFI_25 = 25 , JY5211_PFI_26 = 26 , JY5211_PFI_27 = 27 ,
JY5211_PFI_28 = 28 , JY5211_PFI_29 = 29 , JY5211_PFI_30 = 30 , JY5211_PFI_31 = 31 ,
JY5211_PFI_32 = 32 , JY5211_PFI_33 = 33 , JY5211_PFI_34 = 34 , JY5211_PFI_35 = 35 ,
JY5211_PFI_36 = 36 , JY5211_PFI_37 = 37 , JY5211_PFI_38 = 38 , JY5211_PFI_39 = 39 ,
JY5211_PXITrig_0 = 40 , JY5211_PXITrig_1 = 41 , JY5211_PXITrig_2 = 42 , JY5211_PXITrig_3 = 43 ,
JY5211_PXITrig_4 = 44 , JY5211_PXITrig_5 = 45 , JY5211_PXITrig_6 = 46 , JY5211_PXITrig_7 = 47 ,
JY5211_PXI_Star = 48
}
enum JY5211_InputTerminal {
JY5211_In_PFI_0 = 0 , JY5211_In_PFI_1 = 1 , JY5211_In_PFI_2 = 2 , JY5211_In_PFI_3 = 3 ,
JY5211_In_PFI_4 = 4 , JY5211_In_PFI_5 = 5 , JY5211_In_PFI_6 = 6 , JY5211_In_PFI_7 = 7 ,
JY5211_In_PFI_8 = 8 , JY5211_In_PFI_9 = 9 , JY5211_In_PFI_10 = 10 , JY5211_In_PFI_11 = 11 ,
JY5211_In_PFI_12 = 12 , JY5211_In_PFI_13 = 13 , JY5211_In_PFI_14 = 14 , JY5211_In_PFI_15 = 15 ,
JY5211_In_PFI_16 = 16 , JY5211_In_PFI_17 = 17 , JY5211_In_PFI_18 = 18 , JY5211_In_PFI_19 = 19 ,
JY5211_In_PFI_20 = 20 , JY5211_In_PFI_21 = 21 , JY5211_In_PFI_22 = 22 , JY5211_In_PFI_23 = 23 ,
JY5211_In_PFI_24 = 24 , JY5211_In_PFI_25 = 25 , JY5211_In_PFI_26 = 26 , JY5211_In_PFI_27 = 27 ,
JY5211_In_PFI_28 = 28 , JY5211_In_PFI_29 = 29 , JY5211_In_PFI_30 = 30 , JY5211_In_PFI_31 = 31 ,
JY5211_In_PFI_32 = 32 , JY5211_In_PFI_33 = 33 , JY5211_In_PFI_34 = 34 , JY5211_In_PFI_35 = 35 ,
JY5211_In_PFI_36 = 36 , JY5211_In_PFI_37 = 37 , JY5211_In_PFI_38 = 38 , JY5211_In_PFI_39 = 39 ,
JY5211_In_PXITrig_0 = 40 , JY5211_In_PXITrig_1 = 41 , JY5211_In_PXITrig_2 = 42 , JY5211_In_PXITrig_3 = 43 ,
JY5211_In_PXITrig_4 = 44 , JY5211_In_PXITrig_5 = 45 , JY5211_In_PXITrig_6 = 46 , JY5211_In_PXITrig_7 = 47 ,
JY5211_In_PXI_Star = 48 , JY5211_In_TimeBase_50M = 49 , JY5211_In_TimeBase_5M = 50 , JY5211_In_TimeBase_100K = 51 ,
JY5211_In_CO_0_Output = 52 , JY5211_In_CO_1_Output = 53 , JY5211_In_CO_2_Output = 54 , JY5211_In_CO_3_Output = 55 ,
JY5211_In_CO_4_Output = 56 , JY5211_In_CO_5_Output = 57 , JY5211_In_CO_6_Output = 58 , JY5211_In_CO_7_Output = 59
}
enum JY5211_TriggerTerminal {
JY5211_Trigger_PFI_0 = 0 , JY5211_Trigger_PFI_1 = 1 , JY5211_Trigger_PFI_2 = 2 , JY5211_Trigger_PFI_3 = 3 ,
JY5211_Trigger_PFI_4 = 4 , JY5211_Trigger_PFI_5 = 5 , JY5211_Trigger_PFI_6 = 6 , JY5211_Trigger_PFI_7 = 7 ,
JY5211_Trigger_PFI_8 = 8 , JY5211_Trigger_PFI_9 = 9 , JY5211_Trigger_PFI_10 = 10 , JY5211_Trigger_PFI_11 = 11 ,
JY5211_Trigger_PFI_12 = 12 , JY5211_Trigger_PFI_13 = 13 , JY5211_Trigger_PFI_14 = 14 , JY5211_Trigger_PFI_15 = 15 ,
JY5211_Trigger_PFI_16 = 16 , JY5211_Trigger_PFI_17 = 17 , JY5211_Trigger_PFI_18 = 18 , JY5211_Trigger_PFI_19 = 19 ,
JY5211_Trigger_PFI_20 = 20 , JY5211_Trigger_PFI_21 = 21 , JY5211_Trigger_PFI_22 = 22 , JY5211_Trigger_PFI_23 = 23 ,
JY5211_Trigger_PFI_24 = 24 , JY5211_Trigger_PFI_25 = 25 , JY5211_Trigger_PFI_26 = 26 , JY5211_Trigger_PFI_27 = 27 ,
JY5211_Trigger_PFI_28 = 28 , JY5211_Trigger_PFI_29 = 29 , JY5211_Trigger_PFI_30 = 30 , JY5211_Trigger_PFI_31 = 31 ,
JY5211_Trigger_PFI_32 = 32 , JY5211_Trigger_PFI_33 = 33 , JY5211_Trigger_PFI_34 = 34 , JY5211_Trigger_PFI_35 = 35 ,
JY5211_Trigger_PFI_36 = 36 , JY5211_Trigger_PFI_37 = 37 , JY5211_Trigger_PFI_38 = 38 , JY5211_Trigger_PFI_39 = 39 ,
JY5211_Trigger_PXITrig_0 = 40 , JY5211_Trigger_PXITrig_1 = 41 , JY5211_Trigger_PXITrig_2 = 42 , JY5211_Trigger_PXITrig_3 = 43 ,
JY5211_Trigger_PXITrig_4 = 44 , JY5211_Trigger_PXITrig_5 = 45 , JY5211_Trigger_PXITrig_6 = 46 , JY5211_Trigger_PXITrig_7 = 47 ,
JY5211_Trigger_PXI_Star = 48 , JY5211_Trigger_CO_0_Output = 49 , JY5211_Trigger_CO_1_Output = 50 , JY5211_Trigger_CO_2_Output = 51 ,
JY5211_Trigger_CO_3_Output = 52 , JY5211_Trigger_CO_4_Output = 53 , JY5211_Trigger_CO_5_Output = 54 , JY5211_Trigger_CO_6_Output = 55 ,
JY5211_Trigger_CO_7_Output = 56 , JY5211_Trigger_CI_0_StartTrig = 57 , JY5211_Trigger_CI_1_StartTrig = 58 , JY5211_Trigger_CI_2_StartTrig = 59 ,
JY5211_Trigger_CI_3_StartTrig = 60 , JY5211_Trigger_CI_4_StartTrig = 61 , JY5211_Trigger_CI_5_StartTrig = 62 , JY5211_Trigger_CI_6_StartTrig = 63 ,
JY5211_Trigger_CI_7_StartTrig = 64 , JY5211_Trigger_CO_0_StartTrig = 65 , JY5211_Trigger_CO_1_StartTrig = 66 , JY5211_Trigger_CO_2_StartTrig = 67 ,
JY5211_Trigger_CO_3_StartTrig = 68 , JY5211_Trigger_CO_4_StartTrig = 69 , JY5211_Trigger_CO_5_StartTrig = 70 , JY5211_Trigger_CO_6_StartTrig = 71 ,
JY5211_Trigger_CO_7_StartTrig = 72
}
enum JY5211_ClockTerminal {
JY5211_Clock_PFI_0 = 0 , JY5211_Clock_PFI_1 = 1 , JY5211_Clock_PFI_2 = 2 , JY5211_Clock_PFI_3 = 3 ,
JY5211_Clock_PFI_4 = 4 , JY5211_Clock_PFI_5 = 5 , JY5211_Clock_PFI_6 = 6 , JY5211_Clock_PFI_7 = 7 ,
JY5211_Clock_PFI_8 = 8 , JY5211_Clock_PFI_9 = 9 , JY5211_Clock_PFI_10 = 10 , JY5211_Clock_PFI_11 = 11 ,
JY5211_Clock_PFI_12 = 12 , JY5211_Clock_PFI_13 = 13 , JY5211_Clock_PFI_14 = 14 , JY5211_Clock_PFI_15 = 15 ,
JY5211_Clock_PFI_16 = 16 , JY5211_Clock_PFI_17 = 17 , JY5211_Clock_PFI_18 = 18 , JY5211_Clock_PFI_19 = 19 ,
JY5211_Clock_PFI_20 = 20 , JY5211_Clock_PFI_21 = 21 , JY5211_Clock_PFI_22 = 22 , JY5211_Clock_PFI_23 = 23 ,
JY5211_Clock_PFI_24 = 24 , JY5211_Clock_PFI_25 = 25 , JY5211_Clock_PFI_26 = 26 , JY5211_Clock_PFI_27 = 27 ,
JY5211_Clock_PFI_28 = 28 , JY5211_Clock_PFI_29 = 29 , JY5211_Clock_PFI_30 = 30 , JY5211_Clock_PFI_31 = 31 ,
JY5211_Clock_PFI_32 = 32 , JY5211_Clock_PFI_33 = 33 , JY5211_Clock_PFI_34 = 34 , JY5211_Clock_PFI_35 = 35 ,
JY5211_Clock_PFI_36 = 36 , JY5211_Clock_PFI_37 = 37 , JY5211_Clock_PFI_38 = 38 , JY5211_Clock_PFI_39 = 39 ,
JY5211_Clock_PXITrig_0 = 40 , JY5211_Clock_PXITrig_1 = 41 , JY5211_Clock_PXITrig_2 = 42 , JY5211_Clock_PXITrig_3 = 43 ,
JY5211_Clock_PXITrig_4 = 44 , JY5211_Clock_PXITrig_5 = 45 , JY5211_Clock_PXITrig_6 = 46 , JY5211_Clock_PXITrig_7 = 47 ,
JY5211_Clock_PXI_Star = 48 , JY5211_Clock_CO_0_Output = 49 , JY5211_Clock_CO_1_Output = 50 , JY5211_Clock_CO_2_Output = 51 ,
JY5211_Clock_CO_3_Output = 52 , JY5211_Clock_CO_4_Output = 53 , JY5211_Clock_CO_5_Output = 54 , JY5211_Clock_CO_6_Output = 55 ,
JY5211_Clock_CO_7_Output = 56 , JY5211_Clock_CI_0_SampleClock = 57 , JY5211_Clock_CI_1_SampleClock = 58 , JY5211_Clock_CI_2_SampleClock = 59 ,
JY5211_Clock_CI_3_SampleClock = 60 , JY5211_Clock_CI_4_SampleClock = 61 , JY5211_Clock_CI_5_SampleClock = 62 , JY5211_Clock_CI_6_SampleClock = 63 ,
JY5211_Clock_CI_7_SampleClock = 64
}
enum JY5211_Signal_Source {
JY5211_Internal_TimeBase_5M = 4 , JY5211_Internal_TimeBase_100K = 5 , JY5211_Internal_TimeBase_50M = 7 , JY5211_CI_0_SampleClock = 8 ,
JY5211_CI_1_SampleClock = 9 , JY5211_CI_2_SampleClock = 10 , JY5211_CI_3_SampleClock = 11 , JY5211_CI_4_SampleClock = 12 ,
JY5211_CI_5_SampleClock = 13 , JY5211_CI_6_SampleClock = 14 , JY5211_CI_7_SampleClock = 15 , JY5211_CO_0_Output = 16 ,
JY5211_CO_1_Output = 17 , JY5211_CO_2_Output = 18 , JY5211_CO_3_Output = 19 , JY5211_CO_4_Output = 20 ,
JY5211_CO_5_Output = 21 , JY5211_CO_6_Output = 22 , JY5211_CO_7_Output = 23 , JY5211_CI_0_StartTrig = 24 ,
JY5211_CI_1_StartTrig = 25 , JY5211_CI_2_StartTrig = 26 , JY5211_CI_3_StartTrig = 27 , JY5211_CI_4_StartTrig = 28 ,
JY5211_CI_5_StartTrig = 29 , JY5211_CI_6_StartTrig = 30 , JY5211_CI_7_StartTrig = 31 , JY5211_CO_0_StartTrig = 32 ,
JY5211_CO_1_StartTrig = 33 , JY5211_CO_2_StartTrig = 34 , JY5211_CO_3_StartTrig = 35 , JY5211_CO_4_StartTrig = 36 ,
JY5211_CO_5_StartTrig = 37 , JY5211_CO_6_StartTrig = 38 , JY5211_CO_7_StartTrig = 39
}

Functions

JY5211API int | JY5211_Open (int slotNumber, JY5211_DeviceHandle *hDevice)
Open the 5211 board using the slot number or the board serial number. More...
JY5211API int | JY5211_OpenByName (const char *cardName, JY5211_DeviceHandle *hDevice)
Open this 5211 board using the board alias name which is set by JYTEK utility JYDM. More...
JY5211API int | JY5211_GetDeviceID (JY5211_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY5211API int | JY5211_GetDeviceSerialNumber (JY5211_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5211API int | JY5211_Close (JY5211_DeviceHandle hDevice)
Close this 5211 board. More...
JY5211API int | JY5211_SetPFIPower (JY5211_DeviceHandle hDevice, JY5211_Power_Level powerLevel)
Set PFI power level More...
JY5211API int | JY5211_SetPFIFilter (JY5211_DeviceHandle hDevice, JY5211_IOTerminal line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI More...
JY5211API int | JY5211_SetDeviceReferenceClock (JY5211_DeviceHandle hDevice, JY5211_ReferenceClock refClkSource, int refClkSourceFreq)
Set ReferenceClock for the device.PCIe device only supports internal reference clock. More...
JY5211API int | JY5211_SignalRouting (JY5211_DeviceHandle hDevice, JY5211_Signal_Source source, JY5211_IOTerminal destination)
Route a singal from source to destination. More...
JY5211API int | JY5211_DisconnectSignalRouting (JY5211_DeviceHandle hDevice, JY5211_IOTerminal destination)
Disconnect an established routing. More...
JY5211API int | JY5211_GetCurrentReferenceClock (JY5211_DeviceHandle hDevice, JY5211_ReferenceClock *refClkSource)
Get reference clock source for the device. More...
JY5211API int | JY5211_CI_EnableChannel (JY5211_DeviceHandle hDevice, unsigned int channel)
Enables CI channel. More...
JY5211API int | JY5211_CI_SetCounterType (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CI_MeasureType measureType)
Set CI measure type More...
JY5211API int | JY5211_CI_SetCounterParament (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int initCount, JY5211_CountDirection countDirection)
Set CI edge count parameter More...
JY5211API int | JY5211_CI_SetSourceTermianl (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_InputTerminal sourceTerminal)
Set CI Source Terminal More...
JY5211API int | JY5211_CI_SetGateTermianl (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_InputTerminal gateTerminal)
Set CI Gate Terminal More...
JY5211API int | JY5211_CI_SetAuxTermianl (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_InputTerminal auxTerminal)
Set CI Aux Terminal More...
JY5211API int | JY5211_CI_SetEdgeCountEventTerminal (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_IOTerminal evtTerminal)
Set CI edge count Event Output signal Terminal More...
JY5211API int | JY5211_CI_SetEdgeCountEvent (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter edge count Event threshold, and when the count reaches this threshold, output a single pulse at the output terminal More...
JY5211API int | JY5211_CI_SetSignalReverse (JY5211_DeviceHandle hDevice, unsigned int channel, int reverseMask)
Set the Signal Reverse terminal. More...
JY5211API int | JY5211_CI_SetZReloadEnabled (JY5211_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode. More...
JY5211API int | JY5211_CI_SetSampleMode (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5211_CI_SampleMode. More...
JY5211API int | JY5211_CI_SetSampleClock (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CI_SampleClock clock, JY5211_ClockTerminal externalSampleClkTerminal, double sampleRate)
Set CI Sample Clock More...
JY5211API int | JY5211_CI_GetActualSampleRate (double baseFrequency, double requiredSampleRate, double *actualSampleRate)
Get Actual Sample Rate More...
JY5211API int | JY5211_CI_SetTimebase (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_TimebaseSource timebaseSrc, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter input time base,the time base defined by enum JY5211_TimebaseSource. More...
JY5211API int | JY5211_CI_SetSamplesToAcquire (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M. More...
JY5211API int | JY5211_CI_ReadSingleCountValue (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type : JY5211_CI_EdgeCount、 JY5211_CI_EncoderX1、 JY5211_CI_EncoderX2 、 JY5211_CI_EncoderX4 、JY5211_CI_EncoderTwoPulse. More...
JY5211API int | JY5211_CI_ReadSingleMeasureValue (JY5211_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeout)
Reads single counter measurement. More...
JY5211API int | JY5211_CI_ReadCountValues (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5211_CI_EdgeCount、JY5211_CI_EncoderX1、JY5211_CI_EncoderX2、JY5211_CI_EncoderX4 、JY5211_CI_EncoderTwoPulse. More...
JY5211API int | JY5211_CI_ReadMeasureValues (JY5211_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type ：JY5211_CI_Measure_EdgeSeparation JY5211_CI_Measure_Pulse JY5211_CI_Measure_FrequencyOrPeriod for JY5211_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. More...
JY5211API int | JY5211_CI_Start (JY5211_DeviceHandle hDevice, unsigned int channel)
Start counter input. More...
JY5211API int | JY5211_CI_Stop (JY5211_DeviceHandle hDevice, unsigned int channel)
Stop counter input. More...
JY5211API int | JY5211_CI_CheckBufferStatus (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status. More...
JY5211API int | JY5211_CI_SendSoftTrigger (JY5211_DeviceHandle hDevice, unsigned int channel)
Send software trigger signal. More...
JY5211API int | JY5211_CI_SetStartTriggerType (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CIO_StartTriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5211_CIO_StartTriggerType. More...
JY5211API int | JY5211_CI_SetDigitalStartTrigger (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_TriggerTerminal triggerSource, JY5211_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5211_IOTerminal, the triggerEdge is defined by enum JY5211_DigitalTriggerEdge. More...
JY5211API int | JY5211_CI_SetPauseTriggerLevel (JY5211_DeviceHandle hDevice, unsigned int channel, bool enable, JY5211_LevelState pauseTriggerActiveLevel)
Config CI pause trigger. More...
JY5211API int | JY5211_CI_ConfigSync (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_SyncMode syncMode, JY5211_IOTerminal terminal)
Config CI sync mode. More...
JY5211API int | JY5211_CO_EnableChannel (JY5211_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel. More...
JY5211API int | JY5211_CO_SetCounterParament (JY5211_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5211_LevelState IdleState, double delay)
Set CO parameter. More...
JY5211API int | JY5211_CO_SetSourceTermianl (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_InputTerminal sourceTerminal)
Set CO source terminal. More...
JY5211API int | JY5211_CO_SetTimebase (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_TimebaseSource timebaseSrc, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter out time base,the time base defined by enum JY5211_TimebaseSource. More...
JY5211API int | JY5211_CO_SetOutTermianl (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_IOTerminal outTerminal)
Set counter output terminal. More...
JY5211API int | JY5211_CO_SetSampleMode (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CO_SampleMode mode)
Set counter output mode, the mode defined by enum JY5211_CO_SampleMode. More...
JY5211API int | JY5211_CO_SetSamplesToUpdate (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples. More...
JY5211API int | JY5211_CO_SetFrequency (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency More...
JY5211API int | JY5211_CO_SetFrequencyOnFly (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set the output pulse frequency of the counter in real time. More...
JY5211API int | JY5211_CO_Start (JY5211_DeviceHandle hDevice, unsigned int channel)
Start counter output. More...
JY5211API int | JY5211_CO_Stop (JY5211_DeviceHandle hDevice, unsigned int channel)
Stop counter output. More...
JY5211API int | JY5211_CO_CheckBufferStatus (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status. More...
JY5211API int | JY5211_CO_CheckCounterStatus (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *overrun)
Check counter output pulse status. More...
JY5211API int | JY5211_CO_WriteData (JY5211_DeviceHandle hDevice, unsigned int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses. More...
JY5211API int | JY5211_CO_SendSoftTrigger (JY5211_DeviceHandle hDevice, unsigned int channel)
Send the software trigger signal for CO. More...
JY5211API int | JY5211_CO_SetStartTriggerType (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_CIO_StartTriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5211_CIO_StartTriggerType. More...
JY5211API int | JY5211_CO_SetDigitalStartTrigger (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_TriggerTerminal triggerSource, JY5211_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger.the triggerSource is defined by enum JY5211_IOTerminal, the triggerEdge is defined by enum JY5211_DigitalTriggerEdge. More...
JY5211API int | JY5211_CO_ConfigSync (JY5211_DeviceHandle hDevice, unsigned int channel, JY5211_SyncMode syncMode, JY5211_IOTerminal terminal)
Config CO sync mode. More...
JY5211API int | JY5211_DI_EnableLines (JY5211_DeviceHandle hDevice, JY5211_IOTerminal *lines, unsigned int linesCount)
Enable DI channels. More...
JY5211API int | JY5211_DI_ReadSinglePoint (JY5211_DeviceHandle hDevice, JY5211_IOTerminal *lines, unsigned int linesCount, unsigned int *regValues)
Read single point for each channel to user defined data buffer. More...
JY5211API int | JY5211_DO_EnableLines (JY5211_DeviceHandle hDevice, JY5211_IOTerminal *lines, unsigned int linesCount)
Enable DO channels. More...
JY5211API int | JY5211_DO_WriteSinglePoint (JY5211_DeviceHandle hDevice, JY5211_IOTerminal *lines, unsigned int linesCount, unsigned int *regValues)
DO write single point. More...
JY5211API int | JY5211_CO_WaitUntilDone (JY5211_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status. More...
JY5211API int | JY5211_SetDeviceStatusLed (JY5211_DeviceHandle hDevice, bool enable, double frequency)
Control Front Panel Status Led More...
JY5211API int | JY5211_GetReferenceClockLockedState (JY5211_DeviceHandle hDevice, int *locked)
Check PLL Locked state More...

Detailed Description

@SectionBegin JY5211 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
2.0.2
Date
2022-6-28

This header file defines C/C++ API and enums used in the JY5211 driver.

Revision Notes:

Typedef Documentation

◆ JY5211_DeviceHandle

typedef void* JY5211_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY5211_CI_CounterEventSignalIdleState

enum JY5211_CI_CounterEventSignalIdleState
Enumerator
JY5211_CI_CounterEventSignalIdleState_Low |
JY5211_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JY5211_CI_MeasureType

enum JY5211_CI_MeasureType
Enumerator
JY5211_CI_EdgeCount | Edge count.
JY5211_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JY5211_CI_Measure_PulseWidth | Pulse Measurement.
JY5211_CI_Measure_EdgeSeparation | Two Edge Separation.
JY5211_CI_EncoderX1 | Quadrature Encoded X1.
JY5211_CI_EncoderX2 | Quadrature Encoded X2.
JY5211_CI_EncoderX4 | Quadrature Encoded X4.
JY5211_CI_EncoderTwoPulse | Two Pulse Encoder.

◆ JY5211_CI_SampleClock

enum JY5211_CI_SampleClock
Enumerator
JY5211_CI_NoClk | CI No Clock.
JY5211_CI_ImplicitClk | CI Implicit sample Clock.
JY5211_CI_InternalClk | CI Internal sample Clock.
JY5211_CI_ExternalClk | CI External sample Clock.

◆ JY5211_CI_SampleMode

enum JY5211_CI_SampleMode
Enumerator
JY5211_CI_Single | CI Single mode.
JY5211_CI_Finite | CI Finite mode.
JY5211_CI_Continuous | CI Continuous mode.

◆ JY5211_CIO_StartTriggerType

enum JY5211_CIO_StartTriggerType
Enumerator
JY5211_CI_Immediately | CI Immediately trigger.
JY5211_CI_Digital | CI Digital trigger.
JY5211_CI_Soft | CI Soft trigger.

◆ JY5211_ClockTerminal

enum JY5211_ClockTerminal
Enumerator
JY5211_Clock_PFI_0 | PFI_0 as the Clock source.
JY5211_Clock_PFI_1 | PFI_1 as the Clock source.
JY5211_Clock_PFI_2 | PFI_2 as the Clock source.
JY5211_Clock_PFI_3 | PFI_3 as the Clock source.
JY5211_Clock_PFI_4 | PFI_4 as the Clock source.
JY5211_Clock_PFI_5 | PFI_5 as the Clock source.
JY5211_Clock_PFI_6 | PFI_6 as the Clock source.
JY5211_Clock_PFI_7 | PFI_7 as the Clock source.
JY5211_Clock_PFI_8 | PFI_8 as the Clock source.
JY5211_Clock_PFI_9 | PFI_9 as the Clock source.
JY5211_Clock_PFI_10 | PFI_10 as the Clock source.
JY5211_Clock_PFI_11 | PFI_11 as the Clock source.
JY5211_Clock_PFI_12 | PFI_12 as the Clock source.
JY5211_Clock_PFI_13 | PFI_13 as the Clock source.
JY5211_Clock_PFI_14 | PFI_14 as the Clock source.
JY5211_Clock_PFI_15 | PFI_15 as the Clock source.
JY5211_Clock_PFI_16 | PFI_16 as the Clock source.
JY5211_Clock_PFI_17 | PFI_17 as the Clock source.
JY5211_Clock_PFI_18 | PFI_18 as the Clock source.
JY5211_Clock_PFI_19 | PFI_19 as the Clock source.
JY5211_Clock_PFI_20 | PFI_20 as the Clock source.
JY5211_Clock_PFI_21 | PFI_21 as the Clock source.
JY5211_Clock_PFI_22 | PFI_22 as the Clock source.
JY5211_Clock_PFI_23 | PFI_23 as the Clock source.
JY5211_Clock_PFI_24 | PFI_24 as the Clock source.
JY5211_Clock_PFI_25 | PFI_25 as the Clock source.
JY5211_Clock_PFI_26 | PFI_26 as the Clock source.
JY5211_Clock_PFI_27 | PFI_27 as the Clock source.
JY5211_Clock_PFI_28 | PFI_28 as the Clock source.
JY5211_Clock_PFI_29 | PFI_29 as the Clock source.
JY5211_Clock_PFI_30 | PFI_30 as the Clock source.
JY5211_Clock_PFI_31 | PFI_31 as the Clock source.
JY5211_Clock_PFI_32 | PFI_32 as the Clock source.
JY5211_Clock_PFI_33 | PFI_33 as the Clock source.
JY5211_Clock_PFI_34 | PFI_34 as the Clock source.
JY5211_Clock_PFI_35 | PFI_35 as the Clock source.
JY5211_Clock_PFI_36 | PFI_36 as the Clock source.
JY5211_Clock_PFI_37 | PFI_37 as the ClockClock source.
JY5211_Clock_PFI_38 | PFI_38 as the Clock source.
JY5211_Clock_PFI_39 | PFI_39 as the Clock source.
JY5211_Clock_PXITrig_0 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_1 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_2 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_3 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_4 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_5 | PXITrig_0 as the Clock source.
JY5211_Clock_PXITrig_6 | PXITrig_0 as the ClockClock source.
JY5211_Clock_PXITrig_7 | PXITrig_0 as the ClockClock source.
JY5211_Clock_PXI_Star | PXI_Star as the Clock source.
JY5211_Clock_CO_0_Output | CO_0_Output as the Clock source.
JY5211_Clock_CO_1_Output | CO_1_Output as the Clock source.
JY5211_Clock_CO_2_Output | CO_2_Output as the Clock source.
JY5211_Clock_CO_3_Output | CO_3_Output as the Clock source.
JY5211_Clock_CO_4_Output | CO_4_Output as the Clock source.
JY5211_Clock_CO_5_Output | CO_5_Output as the Clock source.
JY5211_Clock_CO_6_Output | CO_6_Output as the Clock source.
JY5211_Clock_CO_7_Output | CO_7_Output as the Clock source.
JY5211_Clock_CI_0_SampleClock | CI0_SampleClock as the Clock source.
JY5211_Clock_CI_1_SampleClock | CI1_SampleClock as the Clock source.
JY5211_Clock_CI_2_SampleClock | CI2_SampleClock as the Clock source.
JY5211_Clock_CI_3_SampleClock | CI3_SampleClock as the Clock source.
JY5211_Clock_CI_4_SampleClock | CI4_SampleClock as the Clock source.
JY5211_Clock_CI_5_SampleClock | CI5_SampleClock as the Clock source.
JY5211_Clock_CI_6_SampleClock | CI6_SampleClock as the Clock source.
JY5211_Clock_CI_7_SampleClock | CI7_SampleClock as the Clock source.

◆ JY5211_CO_SampleMode

enum JY5211_CO_SampleMode
Enumerator
JY5211_CO_Single | CO Single mode.
JY5211_CO_Finite | CO Finte mode.
JY5211_CO_ContinuousWrapping | CO ContinuousWrapping mode.
JY5211_CO_ContinuousNoWrapping | CO ContinuousNoWrapping mode.

◆ JY5211_CountDirection

enum JY5211_CountDirection
Enumerator
JY5211_CI_Count_Up | Increases count.
JY5211_CI_Count_Down | Reduction count.
JY5211_CI_Count_External | External terminal control count direction.

◆ JY5211_DigitalTriggerEdge

enum JY5211_DigitalTriggerEdge
Enumerator
JY5211_Rising | Rsing edge for digital trigger.
JY5211_Falling | Falling edge for digital trigger.

◆ JY5211_InputTerminal

enum JY5211_InputTerminal
Enumerator
JY5211_In_PFI_0 | PFI_0 as the Input terminal.
JY5211_In_PFI_1 | PFI_1 as the Input terminal.
JY5211_In_PFI_2 | PFI_2 as the Input terminal.
JY5211_In_PFI_3 | PFI_3 as the Input terminal.
JY5211_In_PFI_4 | PFI_4 as the Input terminal.
JY5211_In_PFI_5 | PFI_5 as the Input terminal.
JY5211_In_PFI_6 | PFI_6 as the Input terminal.
JY5211_In_PFI_7 | PFI_7 as the Input terminal.
JY5211_In_PFI_8 | PFI_8 as the Input terminal.
JY5211_In_PFI_9 | PFI_9 as the Input terminal.
JY5211_In_PFI_10 | PFI_10 as the Input terminal.
JY5211_In_PFI_11 | PFI_11 as the Input terminal.
JY5211_In_PFI_12 | PFI_12 as the Input terminal.
JY5211_In_PFI_13 | PFI_13 as the Input terminal.
JY5211_In_PFI_14 | PFI_14 as the Input terminal.
JY5211_In_PFI_15 | PFI_15 as the Input terminal.
JY5211_In_PFI_16 | PFI_16 as the Input terminal.
JY5211_In_PFI_17 | PFI_17 as the Input terminal.
JY5211_In_PFI_18 | PFI_18 as the Input terminal.
JY5211_In_PFI_19 | PFI_19 as the Input terminal.
JY5211_In_PFI_20 | PFI_20 as the Input terminal.
JY5211_In_PFI_21 | PFI_21 as the Input terminal.
JY5211_In_PFI_22 | PFI_22 as the Input terminal.
JY5211_In_PFI_23 | PFI_23 as the Input terminal.
JY5211_In_PFI_24 | PFI_24 as the Input terminal.
JY5211_In_PFI_25 | PFI_25 as the Input terminal.
JY5211_In_PFI_26 | PFI_26 as the Input terminal.
JY5211_In_PFI_27 | PFI_27 as the Input terminal.
JY5211_In_PFI_28 | PFI_28 as the Input terminal.
JY5211_In_PFI_29 | PFI_29 as the Input terminal.
JY5211_In_PFI_30 | PFI_30 as the Input terminal.
JY5211_In_PFI_31 | PFI_31 as the Input terminal.
JY5211_In_PFI_32 | PFI_32 as the Input terminal.
JY5211_In_PFI_33 | PFI_33 as the Input terminal.
JY5211_In_PFI_34 | PFI_34 as the Input terminal.
JY5211_In_PFI_35 | PFI_35 as the Input terminal.
JY5211_In_PFI_36 | PFI_36 as the Input terminal.
JY5211_In_PFI_37 | PFI_37 as the Input terminal.
JY5211_In_PFI_38 | PFI_38 as the Input terminal.
JY5211_In_PFI_39 | PFI_39 as the Input terminal.
JY5211_In_PXITrig_0 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_1 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_2 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_3 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_4 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_5 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_6 | PXITrig_0 as the Input terminal.
JY5211_In_PXITrig_7 | PXITrig_0 as the Input terminal.
JY5211_In_PXI_Star | PXI_Star as the Input terminal.
JY5211_In_TimeBase_50M | Internal 50MHz TimeBase as the Input terminal.
JY5211_In_TimeBase_5M | Internal 5MHz TimeBase as the terminal.
JY5211_In_TimeBase_100K | Internal 100KHz TimeBase as the terminal.
JY5211_In_CO_0_Output | CO_0_Output as the Input terminal.
JY5211_In_CO_1_Output | CO_1_Output as the Input terminal.
JY5211_In_CO_2_Output | CO_2_Output as the Input terminal.
JY5211_In_CO_3_Output | CO_3_Output as the Input terminal.
JY5211_In_CO_4_Output | CO_4_Output as the Input terminal.
JY5211_In_CO_5_Output | CO_5_Output as the Input terminal.
JY5211_In_CO_6_Output | CO_6_Output as the Input terminal.
JY5211_In_CO_7_Output | CO_7_Output as the Input terminal.

◆ JY5211_IOTerminal

enum JY5211_IOTerminal
Enumerator
JY5211_PFI_0 | PFI_0.
JY5211_PFI_1 | PFI_1.
JY5211_PFI_2 | PFI_2.
JY5211_PFI_3 | PFI_3.
JY5211_PFI_4 | PFI_4.
JY5211_PFI_5 | PFI_5.
JY5211_PFI_6 | PFI_6.
JY5211_PFI_7 | PFI_7.
JY5211_PFI_8 | PFI_8.
JY5211_PFI_9 | PFI_9.
JY5211_PFI_10 | PFI_10.
JY5211_PFI_11 | PFI_11.
JY5211_PFI_12 | PFI_12.
JY5211_PFI_13 | PFI_13.
JY5211_PFI_14 | PFI_14.
JY5211_PFI_15 | PFI_15.
JY5211_PFI_16 | PFI_16.
JY5211_PFI_17 | PFI_17.
JY5211_PFI_18 | PFI_18.
JY5211_PFI_19 | PFI_19.
JY5211_PFI_20 | PFI_20.
JY5211_PFI_21 | PFI_21.
JY5211_PFI_22 | PFI_22.
JY5211_PFI_23 | PFI_23.
JY5211_PFI_24 | PFI_24.
JY5211_PFI_25 | PFI_25.
JY5211_PFI_26 | PFI_26.
JY5211_PFI_27 | PFI_27.
JY5211_PFI_28 | PFI_28.
JY5211_PFI_29 | PFI_29.
JY5211_PFI_30 | PFI_30.
JY5211_PFI_31 | PFI_31.
JY5211_PFI_32 | PFI_32.
JY5211_PFI_33 | PFI_33.
JY5211_PFI_34 | PFI_34.
JY5211_PFI_35 | PFI_35.
JY5211_PFI_36 | PFI_36.
JY5211_PFI_37 | PFI_37.
JY5211_PFI_38 | PFI_38.
JY5211_PFI_39 | PFI_39.
JY5211_PXITrig_0 | PXITrig_0.
JY5211_PXITrig_1 | PXITrig_0.
JY5211_PXITrig_2 | PXITrig_0.
JY5211_PXITrig_3 | PXITrig_0.
JY5211_PXITrig_4 | PXITrig_0.
JY5211_PXITrig_5 | PXITrig_0.
JY5211_PXITrig_6 | PXITrig_0.
JY5211_PXITrig_7 | PXITrig_0.
JY5211_PXI_Star | PXI_Star.

◆ JY5211_LevelState

enum JY5211_LevelState
Enumerator
JY5211_LowLevel | Low Level as the active level.
JY5211_HighLevel | High Level as the active level.

◆ JY5211_Power_Level

enum JY5211_Power_Level
Enumerator
Level_1p8 | power level 1.8V
Level_2p5 | power level 2.5V
Level_3p3 | power level 3.3V
Level_5p0 | power level 5.0V

◆ JY5211_ReferenceClock

enum JY5211_ReferenceClock
Enumerator
JY5211_Internal |
JY5211_PXIe_Clk100 | OnBoard10M for reference clock source.
JY5211_PXIe_DStarA | PXI_CLK100 for reference clock source,only for PXIe module.

◆ JY5211_Signal_Source

enum JY5211_Signal_Source
Enumerator
JY5211_Internal_TimeBase_5M | Internal 5MHz TimeBase as the source signal to rout.
JY5211_Internal_TimeBase_100K | Internal 100KHz TimeBase as the source signal to rout.
JY5211_Internal_TimeBase_50M | Internal 50MHz TimeBase as the source signal to rout.
JY5211_CI_0_SampleClock | CI0_SampleClock as the source signal to rout.
JY5211_CI_1_SampleClock | CI1_SampleClock as the source signal to rout.
JY5211_CI_2_SampleClock | CI2_SampleClock as the source signal to rout.
JY5211_CI_3_SampleClock | CI3_SampleClock as the source signal to rout.
JY5211_CI_4_SampleClock | CI4_SampleClock as the source signal to rout.
JY5211_CI_5_SampleClock | CI5_SampleClock as the source signal to rout.
JY5211_CI_6_SampleClock | CI6_SampleClock as the source signal to rout.
JY5211_CI_7_SampleClock | CI7_SampleClock as the source signal to rout.
JY5211_CO_0_Output | CO_0_Output as the source signal to rout.
JY5211_CO_1_Output | CO_1_Output as the source signal to rout.
JY5211_CO_2_Output | CO_2_Output as the source signal to rout.
JY5211_CO_3_Output | CO_3_Output as the source signal to rout.
JY5211_CO_4_Output | CO_4_Output as the source signal to rout.
JY5211_CO_5_Output | CO_5_Output as the source signal to rout.
JY5211_CO_6_Output | CO_6_Output as the source signal to rout.
JY5211_CO_7_Output | CO_7_Output as the source signal to rout.
JY5211_CI_0_StartTrig | CI0_StartTrig as the source signal to rout.
JY5211_CI_1_StartTrig | CI1_StartTrig as the source signal to rout.
JY5211_CI_2_StartTrig | CI2_StartTrig as the source signal to rout.
JY5211_CI_3_StartTrig | CI3_StartTrig as the source signal to rout.
JY5211_CI_4_StartTrig | CI4_StartTrig as the source signal to rout.
JY5211_CI_5_StartTrig | CI5_StartTrig as the source signal to rout.
JY5211_CI_6_StartTrig | CI6_StartTrig as the source signal to rout.
JY5211_CI_7_StartTrig | CI7_StartTrig as the source signal to rout.
JY5211_CO_0_StartTrig | CO0_StartTrig as the source signal to rout.
JY5211_CO_1_StartTrig | CO1_StartTrig as the source signal to rout.
JY5211_CO_2_StartTrig | CO2_StartTrig as the source signal to rout.
JY5211_CO_3_StartTrig | CO3_StartTrig as the source signal to rout.
JY5211_CO_4_StartTrig | CO4_StartTrig as the source signal to rout.
JY5211_CO_5_StartTrig | CO5_StartTrig as the source signal to rout.
JY5211_CO_6_StartTrig | CO6_StartTrig as the source signal to rout.
JY5211_CO_7_StartTrig | CO7_StartTrig as the source signal to rout.

◆ JY5211_SyncMode

enum JY5211_SyncMode
Enumerator
JY5211_SyncMode_Sole | sole card
JY5211_SyncMode_Master | Master card.
JY5211_SyncMode_Slave | Slave card.

◆ JY5211_TimebaseSource

enum JY5211_TimebaseSource
Enumerator
JY5211_Internal_Timebase_200M |
JY5211_Internal_Timebase_5M | 200MHz Internal TimeBase
JY5211_Internal_Timebase_100K | 50MHz Internal TimeBase
JY5211_External_Timebase | 100KHz Internal TimeBase

◆ JY5211_TriggerTerminal

enum JY5211_TriggerTerminal
Enumerator
JY5211_Trigger_PFI_0 | PFI_0 as the trigger source.
JY5211_Trigger_PFI_1 | PFI_1 as the trigger source.
JY5211_Trigger_PFI_2 | PFI_2 as the trigger source.
JY5211_Trigger_PFI_3 | PFI_3 as the trigger source.
JY5211_Trigger_PFI_4 | PFI_4 as the trigger source.
JY5211_Trigger_PFI_5 | PFI_5 as the trigger source.
JY5211_Trigger_PFI_6 | PFI_6 as the trigger source.
JY5211_Trigger_PFI_7 | PFI_7 as the trigger source.
JY5211_Trigger_PFI_8 | PFI_8 as the trigger source.
JY5211_Trigger_PFI_9 | PFI_9 as the trigger source.
JY5211_Trigger_PFI_10 | PFI_10 as the trigger source.
JY5211_Trigger_PFI_11 | PFI_11 as the trigger source.
JY5211_Trigger_PFI_12 | PFI_12 as the trigger source.
JY5211_Trigger_PFI_13 | PFI_13 as the trigger source.
JY5211_Trigger_PFI_14 | PFI_14 as the trigger source.
JY5211_Trigger_PFI_15 | PFI_15 as the trigger source.
JY5211_Trigger_PFI_16 | PFI_16 as the trigger source.
JY5211_Trigger_PFI_17 | PFI_17 as the trigger source.
JY5211_Trigger_PFI_18 | PFI_18 as the trigger source.
JY5211_Trigger_PFI_19 | PFI_19 as the trigger source.
JY5211_Trigger_PFI_20 | PFI_20 as the trigger source.
JY5211_Trigger_PFI_21 | PFI_21 as the trigger source.
JY5211_Trigger_PFI_22 | PFI_22 as the trigger source.
JY5211_Trigger_PFI_23 | PFI_23 as the trigger source.
JY5211_Trigger_PFI_24 | PFI_24 as the trigger source.
JY5211_Trigger_PFI_25 | PFI_25 as the trigger source.
JY5211_Trigger_PFI_26 | PFI_26 as the trigger source.
JY5211_Trigger_PFI_27 | PFI_27 as the trigger source.
JY5211_Trigger_PFI_28 | PFI_28 as the trigger source.
JY5211_Trigger_PFI_29 | PFI_29 as the trigger source.
JY5211_Trigger_PFI_30 | PFI_30 as the trigger source.
JY5211_Trigger_PFI_31 | PFI_31 as the trigger source.
JY5211_Trigger_PFI_32 | PFI_32 as the trigger source.
JY5211_Trigger_PFI_33 | PFI_33 as the trigger source.
JY5211_Trigger_PFI_34 | PFI_34 as the trigger source.
JY5211_Trigger_PFI_35 | PFI_35 as the trigger source.
JY5211_Trigger_PFI_36 | PFI_36 as the trigger source.
JY5211_Trigger_PFI_37 | PFI_37 as the trigger source.
JY5211_Trigger_PFI_38 | PFI_38 as the trigger source.
JY5211_Trigger_PFI_39 | PFI_39 as the trigger source.
JY5211_Trigger_PXITrig_0 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_1 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_2 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_3 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_4 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_5 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_6 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXITrig_7 | PXITrig_0 as the trigger source.
JY5211_Trigger_PXI_Star | PXI_Star as the trigger source.
JY5211_Trigger_CO_0_Output | CO_0_Output as the trigger source.
JY5211_Trigger_CO_1_Output | CO_1_Output as the trigger source.
JY5211_Trigger_CO_2_Output | CO_2_Output as the trigger source.
JY5211_Trigger_CO_3_Output | CO_3_Output as the trigger source.
JY5211_Trigger_CO_4_Output | CO_4_Output as the trigger source.
JY5211_Trigger_CO_5_Output | CO_5_Output as the trigger source.
JY5211_Trigger_CO_6_Output | CO_6_Output as the trigger source.
JY5211_Trigger_CO_7_Output | CO_7_Output as the trigger source.
JY5211_Trigger_CI_0_StartTrig | CI0_StartTrig as the trigger source.
JY5211_Trigger_CI_1_StartTrig | CI1_StartTrig as the trigger source.
JY5211_Trigger_CI_2_StartTrig | CI2_StartTrig as the trigger source.
JY5211_Trigger_CI_3_StartTrig | CI3_StartTrig as the trigger source.
JY5211_Trigger_CI_4_StartTrig | CI4_StartTrig as the trigger source.
JY5211_Trigger_CI_5_StartTrig | CI5_StartTrig as the trigger source.
JY5211_Trigger_CI_6_StartTrig | CI6_StartTrig as the trigger source.
JY5211_Trigger_CI_7_StartTrig | CI7_StartTrig as the trigger source.
JY5211_Trigger_CO_0_StartTrig | CO0_StartTrig as the trigger source.
JY5211_Trigger_CO_1_StartTrig | CO1_StartTrig as the trigger source.
JY5211_Trigger_CO_2_StartTrig | CO2_StartTrig as the trigger source.
JY5211_Trigger_CO_3_StartTrig | CO3_StartTrig as the trigger source.
JY5211_Trigger_CO_4_StartTrig | CO4_StartTrig as the trigger source.
JY5211_Trigger_CO_5_StartTrig | CO5_StartTrig as the trigger source.
JY5211_Trigger_CO_6_StartTrig | CO6_StartTrig as the trigger source.
JY5211_Trigger_CO_7_StartTrig | CO7_StartTrig as the trigger source.

Function Documentation

◆ JY5211_CI_CheckBufferStatus()

JY5211API int JY5211_CI_CheckBufferStatus | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5211_CI_ConfigSync()

JY5211API int JY5211_CI_ConfigSync | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_SyncMode | syncMode,
 |  | JY5211_IOTerminal | terminal
 | ) |  |

Config CI sync mode.

Parameters
hDevice | Device handle
channel | Counter channel
syncMode | Sync mode
terminal | Sync trigger terminal, only valid when sync mode is slave.
Returns
Succeed: 0 , Error: !=0

◆ JY5211_CI_EnableChannel()

JY5211API int JY5211_CI_EnableChannel | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enables CI channel.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5211_CI_GetActualSampleRate()

JY5211API int JY5211_CI_GetActualSampleRate | ( | double | baseFrequency,
 |  | double | requiredSampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Get Actual Sample Rate

Parameters
baseFrequency | Timebase frequency
requiredSampleRate | Required Sample Rate
actualSampleRate | Actual Sample Rate
Returns
0 if success or other error code

◆ JY5211_CI_ReadCountValues()

JY5211API int JY5211_CI_ReadCountValues | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the count values, this API is supprot CI Type ：JY5211_CI_EdgeCount、JY5211_CI_EncoderX1、JY5211_CI_EncoderX2、JY5211_CI_EncoderX4 、JY5211_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5211_CI_ReadMeasureValues()

JY5211API int JY5211_CI_ReadMeasureValues | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the measured values, this API only support CI Type ：JY5211_CI_Measure_EdgeSeparation JY5211_CI_Measure_Pulse JY5211_CI_Measure_FrequencyOrPeriod for JY5211_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s.

for JY5211_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5211_CI_Measure_FrequencyOrPeriod type, measureValues1 is signal frequency in Hz, measureValues2 is signal period in second;

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5211_CI_ReadSingleCountValue()

JY5211API int JY5211_CI_ReadSingleCountValue | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue
 | ) |  |

Counter reads a single count value, this API supports the CI Type : JY5211_CI_EdgeCount、 JY5211_CI_EncoderX1、 JY5211_CI_EncoderX2 、 JY5211_CI_EncoderX4 、JY5211_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel.options:0~7.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5211_CI_ReadSingleMeasureValue()

JY5211API int JY5211_CI_ReadSingleMeasureValue | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeout
 | ) |  |

Reads single counter measurement.

for JY5211_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5211_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5211_CI_Measure_FrequencyOrPeriod type, measureValues1 is signal frequency in Hz, measureValues2 is signal period in second;

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5211_CI_SendSoftTrigger()

JY5211API int JY5211_CI_SendSoftTrigger | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Send software trigger signal.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5211_CI_SetAuxTermianl()

JY5211API int JY5211_CI_SetAuxTermianl | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_InputTerminal | auxTerminal
 | ) |  |

Set CI Aux Terminal

Parameters
hDevice | device handle
channel | counter input channel
auxTerminal | counter input aux terminal.
Returns
0 if success or other error code

◆ JY5211_CI_SetCounterParament()

JY5211API int JY5211_CI_SetCounterParament | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | initCount,
 |  | JY5211_CountDirection | countDirection
 | ) |  |

Set CI edge count parameter

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5211_CountDirection
Returns
0 if success or other error code

◆ JY5211_CI_SetCounterType()

JY5211API int JY5211_CI_SetCounterType | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CI_MeasureType | measureType
 | ) |  |

Set CI measure type

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5211_CI_MeasureType
Returns
0 if success or other error code

◆ JY5211_CI_SetDigitalStartTrigger()

JY5211API int JY5211_CI_SetDigitalStartTrigger | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_TriggerTerminal | triggerSource,
 |  | JY5211_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CI digital start trigger.the triggerSource is defined by enum JY5211_IOTerminal, the triggerEdge is defined by enum JY5211_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5211_CI_SetEdgeCountEvent()

JY5211API int JY5211_CI_SetEdgeCountEvent | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold
 | ) |  |

Set the counter edge count Event threshold, and when the count reaches this threshold, output a single pulse at the output terminal

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5211_CI_SetEdgeCountEventTerminal()

JY5211API int JY5211_CI_SetEdgeCountEventTerminal | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_IOTerminal | evtTerminal
 | ) |  |

Set CI edge count Event Output signal Terminal

Parameters
hDevice | device handle
channel | counter input channel
evtTerminal | edge count Event Output signal Terminal.
Returns
0 if success or other error code

◆ JY5211_CI_SetGateTermianl()

JY5211API int JY5211_CI_SetGateTermianl | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_InputTerminal | gateTerminal
 | ) |  |

Set CI Gate Terminal

Parameters
hDevice | device handle
channel | counter input channel
gateTerminal | counter input gate terminal.
Returns
0 if success or other error code

◆ JY5211_CI_SetPauseTriggerLevel()

JY5211API int JY5211_CI_SetPauseTriggerLevel | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5211_LevelState | pauseTriggerActiveLevel
 | ) |  |

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5211_CI_SetSampleClock()

JY5211API int JY5211_CI_SetSampleClock | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CI_SampleClock | clock,
 |  | JY5211_ClockTerminal | externalSampleClkTerminal,
 |  | double | sampleRate
 | ) |  |

Set CI Sample Clock

Parameters
hDevice | device handle
channel | counter input channel
clock | Sample clock，enum :JY5211_CI_ImplicitClk,JY5211_CI_InternalClk, JY5211_CI_ExternalClk
externalSampleClkTerminal | external sample clock source，valid in clock = JY5211_CI_ExternalClk
sampleRate | sample rate. when clock = JY5211_CI_ExternalClk or clock = JY5211_CI_ImplicitClk, the sample rate is the expected rate
Returns
0 if success or other error code

◆ JY5211_CI_SetSampleMode()

JY5211API int JY5211_CI_SetSampleMode | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CI_SampleMode | mode
 | ) |  |

Set counter input mode, the mode is defined by enum JY5211_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5211_CI_SetSamplesToAcquire()

JY5211API int JY5211_CI_SetSamplesToAcquire | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire
 | ) |  |

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5211_CI_SetSignalReverse()

JY5211API int JY5211_CI_SetSignalReverse | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | reverseMask
 | ) |  |

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
reverseMask | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5211_CI_SetSourceTermianl()

JY5211API int JY5211_CI_SetSourceTermianl | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_InputTerminal | sourceTerminal
 | ) |  |

Set CI Source Terminal

Parameters
hDevice | device handle
channel | counter input channel
sourceTerminal | counter input source terminal.
Returns
0 if success or other error code

◆ JY5211_CI_SetStartTriggerType()

JY5211API int JY5211_CI_SetStartTriggerType | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CIO_StartTriggerType | triggerTyp
 | ) |  |

Set CI start trigger type,the triggerType is defined by enum JY5211_CIO_StartTriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5211_CI_SetTimebase()

JY5211API int JY5211_CI_SetTimebase | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_TimebaseSource | timebaseSrc,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set counter input time base,the time base defined by enum JY5211_TimebaseSource.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5211_CI_SetZReloadEnabled()

JY5211API int JY5211_CI_SetZReloadEnabled | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled
 | ) |  |

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5211_CI_Start()

JY5211API int JY5211_CI_Start | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5211_CI_Stop()

JY5211API int JY5211_CI_Stop | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5211_Close()

JY5211API int JY5211_Close ( JY5211_DeviceHandle hDevice )

Close this 5211 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5211_CO_CheckBufferStatus()

JY5211API int JY5211_CO_CheckBufferStatus | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5211_CO_CheckCounterStatus()

JY5211API int JY5211_CO_CheckCounterStatus | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | overrun
 | ) |  |

Check counter output pulse status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5211_CO_ConfigSync()

JY5211API int JY5211_CO_ConfigSync | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_SyncMode | syncMode,
 |  | JY5211_IOTerminal | terminal
 | ) |  |

Config CO sync mode.

Parameters
hDevice | Device handle
channel | Counter channel
syncMode | Sync mode
terminal | Sync trigger terminal, only valid when sync mode is slave.
Returns
Succeed: 0 , Error: !=0

◆ JY5211_CO_EnableChannel()

JY5211API int JY5211_CO_EnableChannel | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5211_CO_SendSoftTrigger()

JY5211API int JY5211_CO_SendSoftTrigger | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Send the software trigger signal for CO.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5211_CO_SetCounterParament()

JY5211API int JY5211_CO_SetCounterParament | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5211_LevelState | IdleState,
 |  | double | delay
 | ) |  |

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s.
Returns
0 if success or other error code

◆ JY5211_CO_SetDigitalStartTrigger()

JY5211API int JY5211_CO_SetDigitalStartTrigger | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_TriggerTerminal | triggerSource,
 |  | JY5211_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CO digital start trigger.the triggerSource is defined by enum JY5211_IOTerminal, the triggerEdge is defined by enum JY5211_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5211_CO_SetFrequency()

JY5211API int JY5211_CO_SetFrequency | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set counter output pulse frequency

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5211_CO_SetFrequencyOnFly()

JY5211API int JY5211_CO_SetFrequencyOnFly | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set the output pulse frequency of the counter in real time.

After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5211_CO_SetOutTermianl()

JY5211API int JY5211_CO_SetOutTermianl | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_IOTerminal | outTerminal
 | ) |  |

Set counter output terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | signal out terminal
Returns
0 if success or other error code

◆ JY5211_CO_SetSampleMode()

JY5211API int JY5211_CO_SetSampleMode | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CO_SampleMode | mode
 | ) |  |

Set counter output mode, the mode defined by enum JY5211_CO_SampleMode.

Parameters
hDevice | device handle
mode | counter outputput mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5211_CO_SetSamplesToUpdate()

JY5211API int JY5211_CO_SetSamplesToUpdate | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate
 | ) |  |

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5211_CO_SetSourceTermianl()

JY5211API int JY5211_CO_SetSourceTermianl | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_InputTerminal | sourceTerminal
 | ) |  |

Set CO source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source signal terminal
Returns
0 if success or other error code

◆ JY5211_CO_SetStartTriggerType()

JY5211API int JY5211_CO_SetStartTriggerType | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_CIO_StartTriggerType | triggerTyp
 | ) |  |

Set CO start trigger type,the triggerType is defined by enum JY5211_CIO_StartTriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5211_CO_SetTimebase()

JY5211API int JY5211_CO_SetTimebase | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5211_TimebaseSource | timebaseSrc,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set counter out time base,the time base defined by enum JY5211_TimebaseSource.

Parameters
hDevice | device handle
channel | counter output channel
timebaseSrc | counter timebase
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5211_CO_Start()

JY5211API int JY5211_CO_Start | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5211_CO_Stop()

JY5211API int JY5211_CO_Stop | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5211_CO_WaitUntilDone()

JY5211API int JY5211_CO_WaitUntilDone | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done
 | ) |  |

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5211_CO_WriteData()

JY5211API int JY5211_CO_WriteData | ( | JY5211_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualWriteLength
 | ) |  |

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | number of output data
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5211_DI_EnableLines()

JY5211API int JY5211_DI_EnableLines | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal * | lines,
 |  | unsigned int | linesCount
 | ) |  |

Enable DI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
linesCount | number of channels to be enabled
lines | array[channelCount] containing channel IDs
Returns
0 if success or other error code

◆ JY5211_DI_ReadSinglePoint()

JY5211API int JY5211_DI_ReadSinglePoint | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal * | lines,
 |  | unsigned int | linesCount,
 |  | unsigned int * | regValues
 | ) |  |

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
lines | array[channelCount] containing channel IDs
linesCount | number of enabled channels
regValues | user buffer,the size of dataBuffer must be greater than or equal to linesCount.
Returns
0 if success or other error code

◆ JY5211_DisconnectSignalRouting()

JY5211API int JY5211_DisconnectSignalRouting | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5211_Signal_Destination
Returns
0 if success or other error code

◆ JY5211_DO_EnableLines()

JY5211API int JY5211_DO_EnableLines | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal * | lines,
 |  | unsigned int | linesCount
 | ) |  |

Enable DO channels.

Each channel can be independently configured

Parameters
hDevice | device handle
linesCount | number of channels to be enabled
lines | array[channelCount] containing channel IDs
Returns
0 if success or other error code

◆ JY5211_DO_WriteSinglePoint()

JY5211API int JY5211_DO_WriteSinglePoint | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal * | lines,
 |  | unsigned int | linesCount,
 |  | unsigned int * | regValues
 | ) |  |

DO write single point.

Parameters
hDevice | device handle
lines | array[channelCount] containing channel IDs
linesCount | number of enabled channels
regValues | user buffer,the size of dataBuffer must be greater than or equal to linesCount.
Returns
0 if success or other error code

◆ JY5211_GetCurrentReferenceClock()

JY5211API int JY5211_GetCurrentReferenceClock | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_ReferenceClock * | refClkSource
 | ) |  |

Get reference clock source for the device.

Parameters
hDevice | device handle
refClkSource | ReferenceClock source defined by enum JY5211_ReferenceClock
Returns
0 if success or other error code

◆ JY5211_GetDeviceID()

JY5211API int JY5211_GetDeviceID | ( | JY5211_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 5211 is a series of boards. The PXIe-5211 board ID is 0x5211. The PCIe-5211 board ID is 0xA211. The USB-5211 board ID is 0xB211.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5211_GetDeviceSerialNumber()

JY5211API int JY5211_GetDeviceSerialNumber | ( | JY5211_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,lenth is 10
Returns
0 if success or other error code

◆ JY5211_GetReferenceClockLockedState()

JY5211API int JY5211_GetReferenceClockLockedState | ( | JY5211_DeviceHandle | hDevice,
 |  | int * | locked
 | ) |  |

Check PLL Locked state

Parameters
hDevice | device handle
locked | lock state
Returns
0 if success or other error code

◆ JY5211_Open()

JY5211API int JY5211_Open | ( | int | slotNumber,
 |  | JY5211_DeviceHandle * | hDevice
 | ) |  |

Open the 5211 board using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5211_OpenByName()

JY5211API int JY5211_OpenByName | ( | const char * | cardName,
 |  | JY5211_DeviceHandle * | hDevice
 | ) |  |

Open this 5211 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5211_SetDeviceReferenceClock()

JY5211API int JY5211_SetDeviceReferenceClock | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_ReferenceClock | refClkSource,
 |  | int | refClkSourceFreq
 | ) |  |

Set ReferenceClock for the device.PCIe device only supports internal reference clock.

Parameters
hDevice | device handle
refClkSource | ReferenceClock source defined by enum JY5211_ReferenceClock
refClkSourceFreq | external reference clock frequency. When the clkSource is JY5211_PXIe_DStarA, this parament must be set
Returns
0 if success or other error code

◆ JY5211_SetDeviceStatusLed()

JY5211API int JY5211_SetDeviceStatusLed | ( | JY5211_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | double | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5211_SetPFIFilter()

JY5211API int JY5211_SetPFIFilter | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_IOTerminal | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth
 | ) |  |

Set the filter for the specified PFI

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JY5211_SetPFIPower()

JY5211API int JY5211_SetPFIPower | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_Power_Level | powerLevel
 | ) |  |

Set PFI power level

Parameters
hDevice device handle
powerLevel power level.options:1.8V,2.5V,3.3V,5.0V
Returns
0 if success or other error code

◆ JY5211_SignalRouting()

JY5211API int JY5211_SignalRouting | ( | JY5211_DeviceHandle | hDevice,
 |  | JY5211_Signal_Source | source,
 |  | JY5211_IOTerminal | destination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5211_Signal_Source and JY5211_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5211_Signal_Source
destination | destination of the signal defined by enum JY5211_Signal_Destination
Returns
0 if success or other error code


5211 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5211


5211 C++ Programming Manual: D:/5211 Directory Reference

  • D:
  • 5211
5211 Directory Reference

Directories

directory Cpp


5211 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 5211 |
▼ Cpp |
JY5211.h | @SectionBegin JY5211 FileHead


5211 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY5211_CI_0_SampleClock : JY5211.h
  • JY5211_CI_0_StartTrig : JY5211.h
  • JY5211_CI_1_SampleClock : JY5211.h
  • JY5211_CI_1_StartTrig : JY5211.h
  • JY5211_CI_2_SampleClock : JY5211.h
  • JY5211_CI_2_StartTrig : JY5211.h
  • JY5211_CI_3_SampleClock : JY5211.h
  • JY5211_CI_3_StartTrig : JY5211.h
  • JY5211_CI_4_SampleClock : JY5211.h
  • JY5211_CI_4_StartTrig : JY5211.h
  • JY5211_CI_5_SampleClock : JY5211.h
  • JY5211_CI_5_StartTrig : JY5211.h
  • JY5211_CI_6_SampleClock : JY5211.h
  • JY5211_CI_6_StartTrig : JY5211.h
  • JY5211_CI_7_SampleClock : JY5211.h
  • JY5211_CI_7_StartTrig : JY5211.h
  • JY5211_CI_CheckBufferStatus() : JY5211.h
  • JY5211_CI_ConfigSync() : JY5211.h
  • JY5211_CI_Continuous : JY5211.h
  • JY5211_CI_Count_Down : JY5211.h
  • JY5211_CI_Count_External : JY5211.h
  • JY5211_CI_Count_Up : JY5211.h
  • JY5211_CI_CounterEventSignalIdleState : JY5211.h
  • JY5211_CI_CounterEventSignalIdleState_High : JY5211.h
  • JY5211_CI_CounterEventSignalIdleState_Low : JY5211.h
  • JY5211_CI_Digital : JY5211.h
  • JY5211_CI_EdgeCount : JY5211.h
  • JY5211_CI_EnableChannel() : JY5211.h
  • JY5211_CI_EncoderTwoPulse : JY5211.h
  • JY5211_CI_EncoderX1 : JY5211.h
  • JY5211_CI_EncoderX2 : JY5211.h
  • JY5211_CI_EncoderX4 : JY5211.h
  • JY5211_CI_ExternalClk : JY5211.h
  • JY5211_CI_Finite : JY5211.h
  • JY5211_CI_GetActualSampleRate() : JY5211.h
  • JY5211_CI_Immediately : JY5211.h
  • JY5211_CI_ImplicitClk : JY5211.h
  • JY5211_CI_InternalClk : JY5211.h
  • JY5211_CI_Measure_EdgeSeparation : JY5211.h
  • JY5211_CI_Measure_FrequencyOrPeriod : JY5211.h
  • JY5211_CI_Measure_PulseWidth : JY5211.h
  • JY5211_CI_MeasureType : JY5211.h
  • JY5211_CI_NoClk : JY5211.h
  • JY5211_CI_ReadCountValues() : JY5211.h
  • JY5211_CI_ReadMeasureValues() : JY5211.h
  • JY5211_CI_ReadSingleCountValue() : JY5211.h
  • JY5211_CI_ReadSingleMeasureValue() : JY5211.h
  • JY5211_CI_SampleClock : JY5211.h
  • JY5211_CI_SampleMode : JY5211.h
  • JY5211_CI_SendSoftTrigger() : JY5211.h
  • JY5211_CI_SetAuxTermianl() : JY5211.h
  • JY5211_CI_SetCounterParament() : JY5211.h
  • JY5211_CI_SetCounterType() : JY5211.h
  • JY5211_CI_SetDigitalStartTrigger() : JY5211.h
  • JY5211_CI_SetEdgeCountEvent() : JY5211.h
  • JY5211_CI_SetEdgeCountEventTerminal() : JY5211.h
  • JY5211_CI_SetGateTermianl() : JY5211.h
  • JY5211_CI_SetPauseTriggerLevel() : JY5211.h
  • JY5211_CI_SetSampleClock() : JY5211.h
  • JY5211_CI_SetSampleMode() : JY5211.h
  • JY5211_CI_SetSamplesToAcquire() : JY5211.h
  • JY5211_CI_SetSignalReverse() : JY5211.h
  • JY5211_CI_SetSourceTermianl() : JY5211.h
  • JY5211_CI_SetStartTriggerType() : JY5211.h
  • JY5211_CI_SetTimebase() : JY5211.h
  • JY5211_CI_SetZReloadEnabled() : JY5211.h
  • JY5211_CI_Single : JY5211.h
  • JY5211_CI_Soft : JY5211.h
  • JY5211_CI_Start() : JY5211.h
  • JY5211_CI_Stop() : JY5211.h
  • JY5211_CIO_StartTriggerType : JY5211.h
  • JY5211_Clock_CI_0_SampleClock : JY5211.h
  • JY5211_Clock_CI_1_SampleClock : JY5211.h
  • JY5211_Clock_CI_2_SampleClock : JY5211.h
  • JY5211_Clock_CI_3_SampleClock : JY5211.h
  • JY5211_Clock_CI_4_SampleClock : JY5211.h
  • JY5211_Clock_CI_5_SampleClock : JY5211.h
  • JY5211_Clock_CI_6_SampleClock : JY5211.h
  • JY5211_Clock_CI_7_SampleClock : JY5211.h
  • JY5211_Clock_CO_0_Output : JY5211.h
  • JY5211_Clock_CO_1_Output : JY5211.h
  • JY5211_Clock_CO_2_Output : JY5211.h
  • JY5211_Clock_CO_3_Output : JY5211.h
  • JY5211_Clock_CO_4_Output : JY5211.h
  • JY5211_Clock_CO_5_Output : JY5211.h
  • JY5211_Clock_CO_6_Output : JY5211.h
  • JY5211_Clock_CO_7_Output : JY5211.h
  • JY5211_Clock_PFI_0 : JY5211.h
  • JY5211_Clock_PFI_1 : JY5211.h
  • JY5211_Clock_PFI_10 : JY5211.h
  • JY5211_Clock_PFI_11 : JY5211.h
  • JY5211_Clock_PFI_12 : JY5211.h
  • JY5211_Clock_PFI_13 : JY5211.h
  • JY5211_Clock_PFI_14 : JY5211.h
  • JY5211_Clock_PFI_15 : JY5211.h
  • JY5211_Clock_PFI_16 : JY5211.h
  • JY5211_Clock_PFI_17 : JY5211.h
  • JY5211_Clock_PFI_18 : JY5211.h
  • JY5211_Clock_PFI_19 : JY5211.h
  • JY5211_Clock_PFI_2 : JY5211.h
  • JY5211_Clock_PFI_20 : JY5211.h
  • JY5211_Clock_PFI_21 : JY5211.h
  • JY5211_Clock_PFI_22 : JY5211.h
  • JY5211_Clock_PFI_23 : JY5211.h
  • JY5211_Clock_PFI_24 : JY5211.h
  • JY5211_Clock_PFI_25 : JY5211.h
  • JY5211_Clock_PFI_26 : JY5211.h
  • JY5211_Clock_PFI_27 : JY5211.h
  • JY5211_Clock_PFI_28 : JY5211.h
  • JY5211_Clock_PFI_29 : JY5211.h
  • JY5211_Clock_PFI_3 : JY5211.h
  • JY5211_Clock_PFI_30 : JY5211.h
  • JY5211_Clock_PFI_31 : JY5211.h
  • JY5211_Clock_PFI_32 : JY5211.h
  • JY5211_Clock_PFI_33 : JY5211.h
  • JY5211_Clock_PFI_34 : JY5211.h
  • JY5211_Clock_PFI_35 : JY5211.h
  • JY5211_Clock_PFI_36 : JY5211.h
  • JY5211_Clock_PFI_37 : JY5211.h
  • JY5211_Clock_PFI_38 : JY5211.h
  • JY5211_Clock_PFI_39 : JY5211.h
  • JY5211_Clock_PFI_4 : JY5211.h
  • JY5211_Clock_PFI_5 : JY5211.h
  • JY5211_Clock_PFI_6 : JY5211.h
  • JY5211_Clock_PFI_7 : JY5211.h
  • JY5211_Clock_PFI_8 : JY5211.h
  • JY5211_Clock_PFI_9 : JY5211.h
  • JY5211_Clock_PXI_Star : JY5211.h
  • JY5211_Clock_PXITrig_0 : JY5211.h
  • JY5211_Clock_PXITrig_1 : JY5211.h
  • JY5211_Clock_PXITrig_2 : JY5211.h
  • JY5211_Clock_PXITrig_3 : JY5211.h
  • JY5211_Clock_PXITrig_4 : JY5211.h
  • JY5211_Clock_PXITrig_5 : JY5211.h
  • JY5211_Clock_PXITrig_6 : JY5211.h
  • JY5211_Clock_PXITrig_7 : JY5211.h
  • JY5211_ClockTerminal : JY5211.h
  • JY5211_Close() : JY5211.h
  • JY5211_CO_0_Output : JY5211.h
  • JY5211_CO_0_StartTrig : JY5211.h
  • JY5211_CO_1_Output : JY5211.h
  • JY5211_CO_1_StartTrig : JY5211.h
  • JY5211_CO_2_Output : JY5211.h
  • JY5211_CO_2_StartTrig : JY5211.h
  • JY5211_CO_3_Output : JY5211.h
  • JY5211_CO_3_StartTrig : JY5211.h
  • JY5211_CO_4_Output : JY5211.h
  • JY5211_CO_4_StartTrig : JY5211.h
  • JY5211_CO_5_Output : JY5211.h
  • JY5211_CO_5_StartTrig : JY5211.h
  • JY5211_CO_6_Output : JY5211.h
  • JY5211_CO_6_StartTrig : JY5211.h
  • JY5211_CO_7_Output : JY5211.h
  • JY5211_CO_7_StartTrig : JY5211.h
  • JY5211_CO_CheckBufferStatus() : JY5211.h
  • JY5211_CO_CheckCounterStatus() : JY5211.h
  • JY5211_CO_ConfigSync() : JY5211.h
  • JY5211_CO_ContinuousNoWrapping : JY5211.h
  • JY5211_CO_ContinuousWrapping : JY5211.h
  • JY5211_CO_EnableChannel() : JY5211.h
  • JY5211_CO_Finite : JY5211.h
  • JY5211_CO_SampleMode : JY5211.h
  • JY5211_CO_SendSoftTrigger() : JY5211.h
  • JY5211_CO_SetCounterParament() : JY5211.h
  • JY5211_CO_SetDigitalStartTrigger() : JY5211.h
  • JY5211_CO_SetFrequency() : JY5211.h
  • JY5211_CO_SetFrequencyOnFly() : JY5211.h
  • JY5211_CO_SetOutTermianl() : JY5211.h
  • JY5211_CO_SetSampleMode() : JY5211.h
  • JY5211_CO_SetSamplesToUpdate() : JY5211.h
  • JY5211_CO_SetSourceTermianl() : JY5211.h
  • JY5211_CO_SetStartTriggerType() : JY5211.h
  • JY5211_CO_SetTimebase() : JY5211.h
  • JY5211_CO_Single : JY5211.h
  • JY5211_CO_Start() : JY5211.h
  • JY5211_CO_Stop() : JY5211.h
  • JY5211_CO_WaitUntilDone() : JY5211.h
  • JY5211_CO_WriteData() : JY5211.h
  • JY5211_CountDirection : JY5211.h
  • JY5211_DeviceHandle : JY5211.h
  • JY5211_DI_EnableLines() : JY5211.h
  • JY5211_DI_ReadSinglePoint() : JY5211.h
  • JY5211_DigitalTriggerEdge : JY5211.h
  • JY5211_DisconnectSignalRouting() : JY5211.h
  • JY5211_DO_EnableLines() : JY5211.h
  • JY5211_DO_WriteSinglePoint() : JY5211.h
  • JY5211_External_Timebase : JY5211.h
  • JY5211_Falling : JY5211.h
  • JY5211_GetCurrentReferenceClock() : JY5211.h
  • JY5211_GetDeviceID() : JY5211.h
  • JY5211_GetDeviceSerialNumber() : JY5211.h
  • JY5211_GetReferenceClockLockedState() : JY5211.h
  • JY5211_HighLevel : JY5211.h
  • JY5211_In_CO_0_Output : JY5211.h
  • JY5211_In_CO_1_Output : JY5211.h
  • JY5211_In_CO_2_Output : JY5211.h
  • JY5211_In_CO_3_Output : JY5211.h
  • JY5211_In_CO_4_Output : JY5211.h
  • JY5211_In_CO_5_Output : JY5211.h
  • JY5211_In_CO_6_Output : JY5211.h
  • JY5211_In_CO_7_Output : JY5211.h
  • JY5211_In_PFI_0 : JY5211.h
  • JY5211_In_PFI_1 : JY5211.h
  • JY5211_In_PFI_10 : JY5211.h
  • JY5211_In_PFI_11 : JY5211.h
  • JY5211_In_PFI_12 : JY5211.h
  • JY5211_In_PFI_13 : JY5211.h
  • JY5211_In_PFI_14 : JY5211.h
  • JY5211_In_PFI_15 : JY5211.h
  • JY5211_In_PFI_16 : JY5211.h
  • JY5211_In_PFI_17 : JY5211.h
  • JY5211_In_PFI_18 : JY5211.h
  • JY5211_In_PFI_19 : JY5211.h
  • JY5211_In_PFI_2 : JY5211.h
  • JY5211_In_PFI_20 : JY5211.h
  • JY5211_In_PFI_21 : JY5211.h
  • JY5211_In_PFI_22 : JY5211.h
  • JY5211_In_PFI_23 : JY5211.h
  • JY5211_In_PFI_24 : JY5211.h
  • JY5211_In_PFI_25 : JY5211.h
  • JY5211_In_PFI_26 : JY5211.h
  • JY5211_In_PFI_27 : JY5211.h
  • JY5211_In_PFI_28 : JY5211.h
  • JY5211_In_PFI_29 : JY5211.h
  • JY5211_In_PFI_3 : JY5211.h
  • JY5211_In_PFI_30 : JY5211.h
  • JY5211_In_PFI_31 : JY5211.h
  • JY5211_In_PFI_32 : JY5211.h
  • JY5211_In_PFI_33 : JY5211.h
  • JY5211_In_PFI_34 : JY5211.h
  • JY5211_In_PFI_35 : JY5211.h
  • JY5211_In_PFI_36 : JY5211.h
  • JY5211_In_PFI_37 : JY5211.h
  • JY5211_In_PFI_38 : JY5211.h
  • JY5211_In_PFI_39 : JY5211.h
  • JY5211_In_PFI_4 : JY5211.h
  • JY5211_In_PFI_5 : JY5211.h
  • JY5211_In_PFI_6 : JY5211.h
  • JY5211_In_PFI_7 : JY5211.h
  • JY5211_In_PFI_8 : JY5211.h
  • JY5211_In_PFI_9 : JY5211.h
  • JY5211_In_PXI_Star : JY5211.h
  • JY5211_In_PXITrig_0 : JY5211.h
  • JY5211_In_PXITrig_1 : JY5211.h
  • JY5211_In_PXITrig_2 : JY5211.h
  • JY5211_In_PXITrig_3 : JY5211.h
  • JY5211_In_PXITrig_4 : JY5211.h
  • JY5211_In_PXITrig_5 : JY5211.h
  • JY5211_In_PXITrig_6 : JY5211.h
  • JY5211_In_PXITrig_7 : JY5211.h
  • JY5211_In_TimeBase_100K : JY5211.h
  • JY5211_In_TimeBase_50M : JY5211.h
  • JY5211_In_TimeBase_5M : JY5211.h
  • JY5211_InputTerminal : JY5211.h
  • JY5211_Internal : JY5211.h
  • JY5211_Internal_Timebase_100K : JY5211.h
  • JY5211_Internal_TimeBase_100K : JY5211.h
  • JY5211_Internal_Timebase_200M : JY5211.h
  • JY5211_Internal_TimeBase_50M : JY5211.h
  • JY5211_Internal_Timebase_5M : JY5211.h
  • JY5211_Internal_TimeBase_5M : JY5211.h
  • JY5211_IOTerminal : JY5211.h
  • JY5211_LevelState : JY5211.h
  • JY5211_LowLevel : JY5211.h
  • JY5211_Open() : JY5211.h
  • JY5211_OpenByName() : JY5211.h
  • JY5211_PFI_0 : JY5211.h
  • JY5211_PFI_1 : JY5211.h
  • JY5211_PFI_10 : JY5211.h
  • JY5211_PFI_11 : JY5211.h
  • JY5211_PFI_12 : JY5211.h
  • JY5211_PFI_13 : JY5211.h
  • JY5211_PFI_14 : JY5211.h
  • JY5211_PFI_15 : JY5211.h
  • JY5211_PFI_16 : JY5211.h
  • JY5211_PFI_17 : JY5211.h
  • JY5211_PFI_18 : JY5211.h
  • JY5211_PFI_19 : JY5211.h
  • JY5211_PFI_2 : JY5211.h
  • JY5211_PFI_20 : JY5211.h
  • JY5211_PFI_21 : JY5211.h
  • JY5211_PFI_22 : JY5211.h
  • JY5211_PFI_23 : JY5211.h
  • JY5211_PFI_24 : JY5211.h
  • JY5211_PFI_25 : JY5211.h
  • JY5211_PFI_26 : JY5211.h
  • JY5211_PFI_27 : JY5211.h
  • JY5211_PFI_28 : JY5211.h
  • JY5211_PFI_29 : JY5211.h
  • JY5211_PFI_3 : JY5211.h
  • JY5211_PFI_30 : JY5211.h
  • JY5211_PFI_31 : JY5211.h
  • JY5211_PFI_32 : JY5211.h
  • JY5211_PFI_33 : JY5211.h
  • JY5211_PFI_34 : JY5211.h
  • JY5211_PFI_35 : JY5211.h
  • JY5211_PFI_36 : JY5211.h
  • JY5211_PFI_37 : JY5211.h
  • JY5211_PFI_38 : JY5211.h
  • JY5211_PFI_39 : JY5211.h
  • JY5211_PFI_4 : JY5211.h
  • JY5211_PFI_5 : JY5211.h
  • JY5211_PFI_6 : JY5211.h
  • JY5211_PFI_7 : JY5211.h
  • JY5211_PFI_8 : JY5211.h
  • JY5211_PFI_9 : JY5211.h
  • JY5211_Power_Level : JY5211.h
  • JY5211_PXI_Star : JY5211.h
  • JY5211_PXIe_Clk100 : JY5211.h
  • JY5211_PXIe_DStarA : JY5211.h
  • JY5211_PXITrig_0 : JY5211.h
  • JY5211_PXITrig_1 : JY5211.h
  • JY5211_PXITrig_2 : JY5211.h
  • JY5211_PXITrig_3 : JY5211.h
  • JY5211_PXITrig_4 : JY5211.h
  • JY5211_PXITrig_5 : JY5211.h
  • JY5211_PXITrig_6 : JY5211.h
  • JY5211_PXITrig_7 : JY5211.h
  • JY5211_ReferenceClock : JY5211.h
  • JY5211_Rising : JY5211.h
  • JY5211_SetDeviceReferenceClock() : JY5211.h
  • JY5211_SetDeviceStatusLed() : JY5211.h
  • JY5211_SetPFIFilter() : JY5211.h
  • JY5211_SetPFIPower() : JY5211.h
  • JY5211_Signal_Source : JY5211.h
  • JY5211_SignalRouting() : JY5211.h
  • JY5211_SyncMode : JY5211.h
  • JY5211_SyncMode_Master : JY5211.h
  • JY5211_SyncMode_Slave : JY5211.h
  • JY5211_SyncMode_Sole : JY5211.h
  • JY5211_TimebaseSource : JY5211.h
  • JY5211_Trigger_CI_0_StartTrig : JY5211.h
  • JY5211_Trigger_CI_1_StartTrig : JY5211.h
  • JY5211_Trigger_CI_2_StartTrig : JY5211.h
  • JY5211_Trigger_CI_3_StartTrig : JY5211.h
  • JY5211_Trigger_CI_4_StartTrig : JY5211.h
  • JY5211_Trigger_CI_5_StartTrig : JY5211.h
  • JY5211_Trigger_CI_6_StartTrig : JY5211.h
  • JY5211_Trigger_CI_7_StartTrig : JY5211.h
  • JY5211_Trigger_CO_0_Output : JY5211.h
  • JY5211_Trigger_CO_0_StartTrig : JY5211.h
  • JY5211_Trigger_CO_1_Output : JY5211.h
  • JY5211_Trigger_CO_1_StartTrig : JY5211.h
  • JY5211_Trigger_CO_2_Output : JY5211.h
  • JY5211_Trigger_CO_2_StartTrig : JY5211.h
  • JY5211_Trigger_CO_3_Output : JY5211.h
  • JY5211_Trigger_CO_3_StartTrig : JY5211.h
  • JY5211_Trigger_CO_4_Output : JY5211.h
  • JY5211_Trigger_CO_4_StartTrig : JY5211.h
  • JY5211_Trigger_CO_5_Output : JY5211.h
  • JY5211_Trigger_CO_5_StartTrig : JY5211.h
  • JY5211_Trigger_CO_6_Output : JY5211.h
  • JY5211_Trigger_CO_6_StartTrig : JY5211.h
  • JY5211_Trigger_CO_7_Output : JY5211.h
  • JY5211_Trigger_CO_7_StartTrig : JY5211.h
  • JY5211_Trigger_PFI_0 : JY5211.h
  • JY5211_Trigger_PFI_1 : JY5211.h
  • JY5211_Trigger_PFI_10 : JY5211.h
  • JY5211_Trigger_PFI_11 : JY5211.h
  • JY5211_Trigger_PFI_12 : JY5211.h
  • JY5211_Trigger_PFI_13 : JY5211.h
  • JY5211_Trigger_PFI_14 : JY5211.h
  • JY5211_Trigger_PFI_15 : JY5211.h
  • JY5211_Trigger_PFI_16 : JY5211.h
  • JY5211_Trigger_PFI_17 : JY5211.h
  • JY5211_Trigger_PFI_18 : JY5211.h
  • JY5211_Trigger_PFI_19 : JY5211.h
  • JY5211_Trigger_PFI_2 : JY5211.h
  • JY5211_Trigger_PFI_20 : JY5211.h
  • JY5211_Trigger_PFI_21 : JY5211.h
  • JY5211_Trigger_PFI_22 : JY5211.h
  • JY5211_Trigger_PFI_23 : JY5211.h
  • JY5211_Trigger_PFI_24 : JY5211.h
  • JY5211_Trigger_PFI_25 : JY5211.h
  • JY5211_Trigger_PFI_26 : JY5211.h
  • JY5211_Trigger_PFI_27 : JY5211.h
  • JY5211_Trigger_PFI_28 : JY5211.h
  • JY5211_Trigger_PFI_29 : JY5211.h
  • JY5211_Trigger_PFI_3 : JY5211.h
  • JY5211_Trigger_PFI_30 : JY5211.h
  • JY5211_Trigger_PFI_31 : JY5211.h
  • JY5211_Trigger_PFI_32 : JY5211.h
  • JY5211_Trigger_PFI_33 : JY5211.h
  • JY5211_Trigger_PFI_34 : JY5211.h
  • JY5211_Trigger_PFI_35 : JY5211.h
  • JY5211_Trigger_PFI_36 : JY5211.h
  • JY5211_Trigger_PFI_37 : JY5211.h
  • JY5211_Trigger_PFI_38 : JY5211.h
  • JY5211_Trigger_PFI_39 : JY5211.h
  • JY5211_Trigger_PFI_4 : JY5211.h
  • JY5211_Trigger_PFI_5 : JY5211.h
  • JY5211_Trigger_PFI_6 : JY5211.h
  • JY5211_Trigger_PFI_7 : JY5211.h
  • JY5211_Trigger_PFI_8 : JY5211.h
  • JY5211_Trigger_PFI_9 : JY5211.h
  • JY5211_Trigger_PXI_Star : JY5211.h
  • JY5211_Trigger_PXITrig_0 : JY5211.h
  • JY5211_Trigger_PXITrig_1 : JY5211.h
  • JY5211_Trigger_PXITrig_2 : JY5211.h
  • JY5211_Trigger_PXITrig_3 : JY5211.h
  • JY5211_Trigger_PXITrig_4 : JY5211.h
  • JY5211_Trigger_PXITrig_5 : JY5211.h
  • JY5211_Trigger_PXITrig_6 : JY5211.h
  • JY5211_Trigger_PXITrig_7 : JY5211.h
  • JY5211_TriggerTerminal : JY5211.h


  • JY5211_CI_CounterEventSignalIdleState : JY5211.h
  • JY5211_CI_MeasureType : JY5211.h
  • JY5211_CI_SampleClock : JY5211.h
  • JY5211_CI_SampleMode : JY5211.h
  • JY5211_CIO_StartTriggerType : JY5211.h
  • JY5211_ClockTerminal : JY5211.h
  • JY5211_CO_SampleMode : JY5211.h
  • JY5211_CountDirection : JY5211.h
  • JY5211_DigitalTriggerEdge : JY5211.h
  • JY5211_InputTerminal : JY5211.h
  • JY5211_IOTerminal : JY5211.h
  • JY5211_LevelState : JY5211.h
  • JY5211_Power_Level : JY5211.h
  • JY5211_ReferenceClock : JY5211.h
  • JY5211_Signal_Source : JY5211.h
  • JY5211_SyncMode : JY5211.h
  • JY5211_TimebaseSource : JY5211.h
  • JY5211_TriggerTerminal : JY5211.h


- j -

  • JY5211_CI_0_SampleClock : JY5211.h
  • JY5211_CI_0_StartTrig : JY5211.h
  • JY5211_CI_1_SampleClock : JY5211.h
  • JY5211_CI_1_StartTrig : JY5211.h
  • JY5211_CI_2_SampleClock : JY5211.h
  • JY5211_CI_2_StartTrig : JY5211.h
  • JY5211_CI_3_SampleClock : JY5211.h
  • JY5211_CI_3_StartTrig : JY5211.h
  • JY5211_CI_4_SampleClock : JY5211.h
  • JY5211_CI_4_StartTrig : JY5211.h
  • JY5211_CI_5_SampleClock : JY5211.h
  • JY5211_CI_5_StartTrig : JY5211.h
  • JY5211_CI_6_SampleClock : JY5211.h
  • JY5211_CI_6_StartTrig : JY5211.h
  • JY5211_CI_7_SampleClock : JY5211.h
  • JY5211_CI_7_StartTrig : JY5211.h
  • JY5211_CI_Continuous : JY5211.h
  • JY5211_CI_Count_Down : JY5211.h
  • JY5211_CI_Count_External : JY5211.h
  • JY5211_CI_Count_Up : JY5211.h
  • JY5211_CI_CounterEventSignalIdleState_High : JY5211.h
  • JY5211_CI_CounterEventSignalIdleState_Low : JY5211.h
  • JY5211_CI_Digital : JY5211.h
  • JY5211_CI_EdgeCount : JY5211.h
  • JY5211_CI_EncoderTwoPulse : JY5211.h
  • JY5211_CI_EncoderX1 : JY5211.h
  • JY5211_CI_EncoderX2 : JY5211.h
  • JY5211_CI_EncoderX4 : JY5211.h
  • JY5211_CI_ExternalClk : JY5211.h
  • JY5211_CI_Finite : JY5211.h
  • JY5211_CI_Immediately : JY5211.h
  • JY5211_CI_ImplicitClk : JY5211.h
  • JY5211_CI_InternalClk : JY5211.h
  • JY5211_CI_Measure_EdgeSeparation : JY5211.h
  • JY5211_CI_Measure_FrequencyOrPeriod : JY5211.h
  • JY5211_CI_Measure_PulseWidth : JY5211.h
  • JY5211_CI_NoClk : JY5211.h
  • JY5211_CI_Single : JY5211.h
  • JY5211_CI_Soft : JY5211.h
  • JY5211_Clock_CI_0_SampleClock : JY5211.h
  • JY5211_Clock_CI_1_SampleClock : JY5211.h
  • JY5211_Clock_CI_2_SampleClock : JY5211.h
  • JY5211_Clock_CI_3_SampleClock : JY5211.h
  • JY5211_Clock_CI_4_SampleClock : JY5211.h
  • JY5211_Clock_CI_5_SampleClock : JY5211.h
  • JY5211_Clock_CI_6_SampleClock : JY5211.h
  • JY5211_Clock_CI_7_SampleClock : JY5211.h
  • JY5211_Clock_CO_0_Output : JY5211.h
  • JY5211_Clock_CO_1_Output : JY5211.h
  • JY5211_Clock_CO_2_Output : JY5211.h
  • JY5211_Clock_CO_3_Output : JY5211.h
  • JY5211_Clock_CO_4_Output : JY5211.h
  • JY5211_Clock_CO_5_Output : JY5211.h
  • JY5211_Clock_CO_6_Output : JY5211.h
  • JY5211_Clock_CO_7_Output : JY5211.h
  • JY5211_Clock_PFI_0 : JY5211.h
  • JY5211_Clock_PFI_1 : JY5211.h
  • JY5211_Clock_PFI_10 : JY5211.h
  • JY5211_Clock_PFI_11 : JY5211.h
  • JY5211_Clock_PFI_12 : JY5211.h
  • JY5211_Clock_PFI_13 : JY5211.h
  • JY5211_Clock_PFI_14 : JY5211.h
  • JY5211_Clock_PFI_15 : JY5211.h
  • JY5211_Clock_PFI_16 : JY5211.h
  • JY5211_Clock_PFI_17 : JY5211.h
  • JY5211_Clock_PFI_18 : JY5211.h
  • JY5211_Clock_PFI_19 : JY5211.h
  • JY5211_Clock_PFI_2 : JY5211.h
  • JY5211_Clock_PFI_20 : JY5211.h
  • JY5211_Clock_PFI_21 : JY5211.h
  • JY5211_Clock_PFI_22 : JY5211.h
  • JY5211_Clock_PFI_23 : JY5211.h
  • JY5211_Clock_PFI_24 : JY5211.h
  • JY5211_Clock_PFI_25 : JY5211.h
  • JY5211_Clock_PFI_26 : JY5211.h
  • JY5211_Clock_PFI_27 : JY5211.h
  • JY5211_Clock_PFI_28 : JY5211.h
  • JY5211_Clock_PFI_29 : JY5211.h
  • JY5211_Clock_PFI_3 : JY5211.h
  • JY5211_Clock_PFI_30 : JY5211.h
  • JY5211_Clock_PFI_31 : JY5211.h
  • JY5211_Clock_PFI_32 : JY5211.h
  • JY5211_Clock_PFI_33 : JY5211.h
  • JY5211_Clock_PFI_34 : JY5211.h
  • JY5211_Clock_PFI_35 : JY5211.h
  • JY5211_Clock_PFI_36 : JY5211.h
  • JY5211_Clock_PFI_37 : JY5211.h
  • JY5211_Clock_PFI_38 : JY5211.h
  • JY5211_Clock_PFI_39 : JY5211.h
  • JY5211_Clock_PFI_4 : JY5211.h
  • JY5211_Clock_PFI_5 : JY5211.h
  • JY5211_Clock_PFI_6 : JY5211.h
  • JY5211_Clock_PFI_7 : JY5211.h
  • JY5211_Clock_PFI_8 : JY5211.h
  • JY5211_Clock_PFI_9 : JY5211.h
  • JY5211_Clock_PXI_Star : JY5211.h
  • JY5211_Clock_PXITrig_0 : JY5211.h
  • JY5211_Clock_PXITrig_1 : JY5211.h
  • JY5211_Clock_PXITrig_2 : JY5211.h
  • JY5211_Clock_PXITrig_3 : JY5211.h
  • JY5211_Clock_PXITrig_4 : JY5211.h
  • JY5211_Clock_PXITrig_5 : JY5211.h
  • JY5211_Clock_PXITrig_6 : JY5211.h
  • JY5211_Clock_PXITrig_7 : JY5211.h
  • JY5211_CO_0_Output : JY5211.h
  • JY5211_CO_0_StartTrig : JY5211.h
  • JY5211_CO_1_Output : JY5211.h
  • JY5211_CO_1_StartTrig : JY5211.h
  • JY5211_CO_2_Output : JY5211.h
  • JY5211_CO_2_StartTrig : JY5211.h
  • JY5211_CO_3_Output : JY5211.h
  • JY5211_CO_3_StartTrig : JY5211.h
  • JY5211_CO_4_Output : JY5211.h
  • JY5211_CO_4_StartTrig : JY5211.h
  • JY5211_CO_5_Output : JY5211.h
  • JY5211_CO_5_StartTrig : JY5211.h
  • JY5211_CO_6_Output : JY5211.h
  • JY5211_CO_6_StartTrig : JY5211.h
  • JY5211_CO_7_Output : JY5211.h
  • JY5211_CO_7_StartTrig : JY5211.h
  • JY5211_CO_ContinuousNoWrapping : JY5211.h
  • JY5211_CO_ContinuousWrapping : JY5211.h
  • JY5211_CO_Finite : JY5211.h
  • JY5211_CO_Single : JY5211.h
  • JY5211_External_Timebase : JY5211.h
  • JY5211_Falling : JY5211.h
  • JY5211_HighLevel : JY5211.h
  • JY5211_In_CO_0_Output : JY5211.h
  • JY5211_In_CO_1_Output : JY5211.h
  • JY5211_In_CO_2_Output : JY5211.h
  • JY5211_In_CO_3_Output : JY5211.h
  • JY5211_In_CO_4_Output : JY5211.h
  • JY5211_In_CO_5_Output : JY5211.h
  • JY5211_In_CO_6_Output : JY5211.h
  • JY5211_In_CO_7_Output : JY5211.h
  • JY5211_In_PFI_0 : JY5211.h
  • JY5211_In_PFI_1 : JY5211.h
  • JY5211_In_PFI_10 : JY5211.h
  • JY5211_In_PFI_11 : JY5211.h
  • JY5211_In_PFI_12 : JY5211.h
  • JY5211_In_PFI_13 : JY5211.h
  • JY5211_In_PFI_14 : JY5211.h
  • JY5211_In_PFI_15 : JY5211.h
  • JY5211_In_PFI_16 : JY5211.h
  • JY5211_In_PFI_17 : JY5211.h
  • JY5211_In_PFI_18 : JY5211.h
  • JY5211_In_PFI_19 : JY5211.h
  • JY5211_In_PFI_2 : JY5211.h
  • JY5211_In_PFI_20 : JY5211.h
  • JY5211_In_PFI_21 : JY5211.h
  • JY5211_In_PFI_22 : JY5211.h
  • JY5211_In_PFI_23 : JY5211.h
  • JY5211_In_PFI_24 : JY5211.h
  • JY5211_In_PFI_25 : JY5211.h
  • JY5211_In_PFI_26 : JY5211.h
  • JY5211_In_PFI_27 : JY5211.h
  • JY5211_In_PFI_28 : JY5211.h
  • JY5211_In_PFI_29 : JY5211.h
  • JY5211_In_PFI_3 : JY5211.h
  • JY5211_In_PFI_30 : JY5211.h
  • JY5211_In_PFI_31 : JY5211.h
  • JY5211_In_PFI_32 : JY5211.h
  • JY5211_In_PFI_33 : JY5211.h
  • JY5211_In_PFI_34 : JY5211.h
  • JY5211_In_PFI_35 : JY5211.h
  • JY5211_In_PFI_36 : JY5211.h
  • JY5211_In_PFI_37 : JY5211.h
  • JY5211_In_PFI_38 : JY5211.h
  • JY5211_In_PFI_39 : JY5211.h
  • JY5211_In_PFI_4 : JY5211.h
  • JY5211_In_PFI_5 : JY5211.h
  • JY5211_In_PFI_6 : JY5211.h
  • JY5211_In_PFI_7 : JY5211.h
  • JY5211_In_PFI_8 : JY5211.h
  • JY5211_In_PFI_9 : JY5211.h
  • JY5211_In_PXI_Star : JY5211.h
  • JY5211_In_PXITrig_0 : JY5211.h
  • JY5211_In_PXITrig_1 : JY5211.h
  • JY5211_In_PXITrig_2 : JY5211.h
  • JY5211_In_PXITrig_3 : JY5211.h
  • JY5211_In_PXITrig_4 : JY5211.h
  • JY5211_In_PXITrig_5 : JY5211.h
  • JY5211_In_PXITrig_6 : JY5211.h
  • JY5211_In_PXITrig_7 : JY5211.h
  • JY5211_In_TimeBase_100K : JY5211.h
  • JY5211_In_TimeBase_50M : JY5211.h
  • JY5211_In_TimeBase_5M : JY5211.h
  • JY5211_Internal : JY5211.h
  • JY5211_Internal_Timebase_100K : JY5211.h
  • JY5211_Internal_TimeBase_100K : JY5211.h
  • JY5211_Internal_Timebase_200M : JY5211.h
  • JY5211_Internal_TimeBase_50M : JY5211.h
  • JY5211_Internal_Timebase_5M : JY5211.h
  • JY5211_Internal_TimeBase_5M : JY5211.h
  • JY5211_LowLevel : JY5211.h
  • JY5211_PFI_0 : JY5211.h
  • JY5211_PFI_1 : JY5211.h
  • JY5211_PFI_10 : JY5211.h
  • JY5211_PFI_11 : JY5211.h
  • JY5211_PFI_12 : JY5211.h
  • JY5211_PFI_13 : JY5211.h
  • JY5211_PFI_14 : JY5211.h
  • JY5211_PFI_15 : JY5211.h
  • JY5211_PFI_16 : JY5211.h
  • JY5211_PFI_17 : JY5211.h
  • JY5211_PFI_18 : JY5211.h
  • JY5211_PFI_19 : JY5211.h
  • JY5211_PFI_2 : JY5211.h
  • JY5211_PFI_20 : JY5211.h
  • JY5211_PFI_21 : JY5211.h
  • JY5211_PFI_22 : JY5211.h
  • JY5211_PFI_23 : JY5211.h
  • JY5211_PFI_24 : JY5211.h
  • JY5211_PFI_25 : JY5211.h
  • JY5211_PFI_26 : JY5211.h
  • JY5211_PFI_27 : JY5211.h
  • JY5211_PFI_28 : JY5211.h
  • JY5211_PFI_29 : JY5211.h
  • JY5211_PFI_3 : JY5211.h
  • JY5211_PFI_30 : JY5211.h
  • JY5211_PFI_31 : JY5211.h
  • JY5211_PFI_32 : JY5211.h
  • JY5211_PFI_33 : JY5211.h
  • JY5211_PFI_34 : JY5211.h
  • JY5211_PFI_35 : JY5211.h
  • JY5211_PFI_36 : JY5211.h
  • JY5211_PFI_37 : JY5211.h
  • JY5211_PFI_38 : JY5211.h
  • JY5211_PFI_39 : JY5211.h
  • JY5211_PFI_4 : JY5211.h
  • JY5211_PFI_5 : JY5211.h
  • JY5211_PFI_6 : JY5211.h
  • JY5211_PFI_7 : JY5211.h
  • JY5211_PFI_8 : JY5211.h
  • JY5211_PFI_9 : JY5211.h
  • JY5211_PXI_Star : JY5211.h
  • JY5211_PXIe_Clk100 : JY5211.h
  • JY5211_PXIe_DStarA : JY5211.h
  • JY5211_PXITrig_0 : JY5211.h
  • JY5211_PXITrig_1 : JY5211.h
  • JY5211_PXITrig_2 : JY5211.h
  • JY5211_PXITrig_3 : JY5211.h
  • JY5211_PXITrig_4 : JY5211.h
  • JY5211_PXITrig_5 : JY5211.h
  • JY5211_PXITrig_6 : JY5211.h
  • JY5211_PXITrig_7 : JY5211.h
  • JY5211_Rising : JY5211.h
  • JY5211_SyncMode_Master : JY5211.h
  • JY5211_SyncMode_Slave : JY5211.h
  • JY5211_SyncMode_Sole : JY5211.h
  • JY5211_Trigger_CI_0_StartTrig : JY5211.h
  • JY5211_Trigger_CI_1_StartTrig : JY5211.h
  • JY5211_Trigger_CI_2_StartTrig : JY5211.h
  • JY5211_Trigger_CI_3_StartTrig : JY5211.h
  • JY5211_Trigger_CI_4_StartTrig : JY5211.h
  • JY5211_Trigger_CI_5_StartTrig : JY5211.h
  • JY5211_Trigger_CI_6_StartTrig : JY5211.h
  • JY5211_Trigger_CI_7_StartTrig : JY5211.h
  • JY5211_Trigger_CO_0_Output : JY5211.h
  • JY5211_Trigger_CO_0_StartTrig : JY5211.h
  • JY5211_Trigger_CO_1_Output : JY5211.h
  • JY5211_Trigger_CO_1_StartTrig : JY5211.h
  • JY5211_Trigger_CO_2_Output : JY5211.h
  • JY5211_Trigger_CO_2_StartTrig : JY5211.h
  • JY5211_Trigger_CO_3_Output : JY5211.h
  • JY5211_Trigger_CO_3_StartTrig : JY5211.h
  • JY5211_Trigger_CO_4_Output : JY5211.h
  • JY5211_Trigger_CO_4_StartTrig : JY5211.h
  • JY5211_Trigger_CO_5_Output : JY5211.h
  • JY5211_Trigger_CO_5_StartTrig : JY5211.h
  • JY5211_Trigger_CO_6_Output : JY5211.h
  • JY5211_Trigger_CO_6_StartTrig : JY5211.h
  • JY5211_Trigger_CO_7_Output : JY5211.h
  • JY5211_Trigger_CO_7_StartTrig : JY5211.h
  • JY5211_Trigger_PFI_0 : JY5211.h
  • JY5211_Trigger_PFI_1 : JY5211.h
  • JY5211_Trigger_PFI_10 : JY5211.h
  • JY5211_Trigger_PFI_11 : JY5211.h
  • JY5211_Trigger_PFI_12 : JY5211.h
  • JY5211_Trigger_PFI_13 : JY5211.h
  • JY5211_Trigger_PFI_14 : JY5211.h
  • JY5211_Trigger_PFI_15 : JY5211.h
  • JY5211_Trigger_PFI_16 : JY5211.h
  • JY5211_Trigger_PFI_17 : JY5211.h
  • JY5211_Trigger_PFI_18 : JY5211.h
  • JY5211_Trigger_PFI_19 : JY5211.h
  • JY5211_Trigger_PFI_2 : JY5211.h
  • JY5211_Trigger_PFI_20 : JY5211.h
  • JY5211_Trigger_PFI_21 : JY5211.h
  • JY5211_Trigger_PFI_22 : JY5211.h
  • JY5211_Trigger_PFI_23 : JY5211.h
  • JY5211_Trigger_PFI_24 : JY5211.h
  • JY5211_Trigger_PFI_25 : JY5211.h
  • JY5211_Trigger_PFI_26 : JY5211.h
  • JY5211_Trigger_PFI_27 : JY5211.h
  • JY5211_Trigger_PFI_28 : JY5211.h
  • JY5211_Trigger_PFI_29 : JY5211.h
  • JY5211_Trigger_PFI_3 : JY5211.h
  • JY5211_Trigger_PFI_30 : JY5211.h
  • JY5211_Trigger_PFI_31 : JY5211.h
  • JY5211_Trigger_PFI_32 : JY5211.h
  • JY5211_Trigger_PFI_33 : JY5211.h
  • JY5211_Trigger_PFI_34 : JY5211.h
  • JY5211_Trigger_PFI_35 : JY5211.h
  • JY5211_Trigger_PFI_36 : JY5211.h
  • JY5211_Trigger_PFI_37 : JY5211.h
  • JY5211_Trigger_PFI_38 : JY5211.h
  • JY5211_Trigger_PFI_39 : JY5211.h
  • JY5211_Trigger_PFI_4 : JY5211.h
  • JY5211_Trigger_PFI_5 : JY5211.h
  • JY5211_Trigger_PFI_6 : JY5211.h
  • JY5211_Trigger_PFI_7 : JY5211.h
  • JY5211_Trigger_PFI_8 : JY5211.h
  • JY5211_Trigger_PFI_9 : JY5211.h
  • JY5211_Trigger_PXI_Star : JY5211.h
  • JY5211_Trigger_PXITrig_0 : JY5211.h
  • JY5211_Trigger_PXITrig_1 : JY5211.h
  • JY5211_Trigger_PXITrig_2 : JY5211.h
  • JY5211_Trigger_PXITrig_3 : JY5211.h
  • JY5211_Trigger_PXITrig_4 : JY5211.h
  • JY5211_Trigger_PXITrig_5 : JY5211.h
  • JY5211_Trigger_PXITrig_6 : JY5211.h
  • JY5211_Trigger_PXITrig_7 : JY5211.h


- l -

  • Level_1p8 : JY5211.h
  • Level_2p5 : JY5211.h
  • Level_3p3 : JY5211.h
  • Level_5p0 : JY5211.h


- j -

  • JY5211_CI_CheckBufferStatus() : JY5211.h
  • JY5211_CI_ConfigSync() : JY5211.h
  • JY5211_CI_EnableChannel() : JY5211.h
  • JY5211_CI_GetActualSampleRate() : JY5211.h
  • JY5211_CI_ReadCountValues() : JY5211.h
  • JY5211_CI_ReadMeasureValues() : JY5211.h
  • JY5211_CI_ReadSingleCountValue() : JY5211.h
  • JY5211_CI_ReadSingleMeasureValue() : JY5211.h
  • JY5211_CI_SendSoftTrigger() : JY5211.h
  • JY5211_CI_SetAuxTermianl() : JY5211.h
  • JY5211_CI_SetCounterParament() : JY5211.h
  • JY5211_CI_SetCounterType() : JY5211.h
  • JY5211_CI_SetDigitalStartTrigger() : JY5211.h
  • JY5211_CI_SetEdgeCountEvent() : JY5211.h
  • JY5211_CI_SetEdgeCountEventTerminal() : JY5211.h
  • JY5211_CI_SetGateTermianl() : JY5211.h
  • JY5211_CI_SetPauseTriggerLevel() : JY5211.h
  • JY5211_CI_SetSampleClock() : JY5211.h
  • JY5211_CI_SetSampleMode() : JY5211.h
  • JY5211_CI_SetSamplesToAcquire() : JY5211.h
  • JY5211_CI_SetSignalReverse() : JY5211.h
  • JY5211_CI_SetSourceTermianl() : JY5211.h
  • JY5211_CI_SetStartTriggerType() : JY5211.h
  • JY5211_CI_SetTimebase() : JY5211.h
  • JY5211_CI_SetZReloadEnabled() : JY5211.h
  • JY5211_CI_Start() : JY5211.h
  • JY5211_CI_Stop() : JY5211.h
  • JY5211_Close() : JY5211.h
  • JY5211_CO_CheckBufferStatus() : JY5211.h
  • JY5211_CO_CheckCounterStatus() : JY5211.h
  • JY5211_CO_ConfigSync() : JY5211.h
  • JY5211_CO_EnableChannel() : JY5211.h
  • JY5211_CO_SendSoftTrigger() : JY5211.h
  • JY5211_CO_SetCounterParament() : JY5211.h
  • JY5211_CO_SetDigitalStartTrigger() : JY5211.h
  • JY5211_CO_SetFrequency() : JY5211.h
  • JY5211_CO_SetFrequencyOnFly() : JY5211.h
  • JY5211_CO_SetOutTermianl() : JY5211.h
  • JY5211_CO_SetSampleMode() : JY5211.h
  • JY5211_CO_SetSamplesToUpdate() : JY5211.h
  • JY5211_CO_SetSourceTermianl() : JY5211.h
  • JY5211_CO_SetStartTriggerType() : JY5211.h
  • JY5211_CO_SetTimebase() : JY5211.h
  • JY5211_CO_Start() : JY5211.h
  • JY5211_CO_Stop() : JY5211.h
  • JY5211_CO_WaitUntilDone() : JY5211.h
  • JY5211_CO_WriteData() : JY5211.h
  • JY5211_DI_EnableLines() : JY5211.h
  • JY5211_DI_ReadSinglePoint() : JY5211.h
  • JY5211_DisconnectSignalRouting() : JY5211.h
  • JY5211_DO_EnableLines() : JY5211.h
  • JY5211_DO_WriteSinglePoint() : JY5211.h
  • JY5211_GetCurrentReferenceClock() : JY5211.h
  • JY5211_GetDeviceID() : JY5211.h
  • JY5211_GetDeviceSerialNumber() : JY5211.h
  • JY5211_GetReferenceClockLockedState() : JY5211.h
  • JY5211_Open() : JY5211.h
  • JY5211_OpenByName() : JY5211.h
  • JY5211_SetDeviceReferenceClock() : JY5211.h
  • JY5211_SetDeviceStatusLed() : JY5211.h
  • JY5211_SetPFIFilter() : JY5211.h
  • JY5211_SetPFIPower() : JY5211.h
  • JY5211_SignalRouting() : JY5211.h


Here is a list of all file members with links to the files they belong to:

- l -

  • Level_1p8 : JY5211.h
  • Level_2p5 : JY5211.h
  • Level_3p3 : JY5211.h
  • Level_5p0 : JY5211.h


  • JY5211_DeviceHandle : JY5211.h


5211 C++ Programming Manual: Main Page

5211 C++ Programming Manual Documentation